Bug 1780584 - openmpi has broken dependencies on armv7hl
Summary: openmpi has broken dependencies on armv7hl
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openmpi
Version: rawhide
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1781765 (view as bug list)
Depends On: 1780813
Blocks: F-ExcludeArch-ARM 1487617
TreeView+ depends on / blocked
 
Reported: 2019-12-06 13:07 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2019-12-11 14:03 UTC (History)
7 users (show)

Fixed In Version: openmpi-4.0.2-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-11 14:03:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2019-12-06 13:07:52 UTC
Description of problem:
openmpi has unresolved dependencies on armv7hl.

Version-Release number of selected component (if applicable):
openmpi-4.0.2-3.fc32

How reproducible:
Always.

Steps to Reproduce:
1. mock -r fedora-rawhide-armhfp install openmpi

Actual results:
...
DEBUG util.py:596:   Problem 1: package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi_cxx.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi_mpifh.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi_usempi_ignore_tkr.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi_usempif08.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires libmpi_java.so.40(openmpi-arm), but none of the providers can be installed
DEBUG util.py:596:    - package openmpi-devel-4.0.2-3.fc32.armv7hl requires openmpi = 4.0.2-3.fc32, but none of the providers can be installed
DEBUG util.py:596:    - conflicting requests
DEBUG util.py:596:    - nothing provides libibverbs.so.1 needed by openmpi-4.0.2-3.fc32.armv7hl
DEBUG util.py:596:    - nothing provides libibverbs.so.1(IBVERBS_1.0) needed by openmpi-4.0.2-3.fc32.armv7hl
DEBUG util.py:596:    - nothing provides libibverbs.so.1(IBVERBS_1.1) needed by openmpi-4.0.2-3.fc32.armv7hl
DEBUG util.py:596:    - nothing provides librdmacm.so.1 needed by openmpi-4.0.2-3.fc32.armv7hl
DEBUG util.py:596:    - nothing provides librdmacm.so.1(RDMACM_1.0) needed by openmpi-4.0.2-3.fc32.armv7hl

Expected results:
Dependencies resolve.

Comment 1 Dominik 'Rathann' Mierzejewski 2019-12-06 13:08:58 UTC
Obviously, the error log is from `mock -r fedora-rawhide-armhfp install openmpi-devel`.

Comment 2 Orion Poplawski 2019-12-07 06:06:11 UTC
Apparently rdma-core-26.1-1.fc32 dropped support for arm.  I've posted a message asking for clarification, but at the moment we need to propagate a bunch of arm conditionals.

Comment 4 Dominik 'Rathann' Mierzejewski 2019-12-11 10:07:56 UTC
*** Bug 1781765 has been marked as a duplicate of this bug. ***

Comment 5 Dominik 'Rathann' Mierzejewski 2019-12-11 10:29:07 UTC
Builds almost fine without rdma-core-devel, but a single file doesn't get installed then: 
Processing files: openmpi-4.0.2-4.fc32.armv7hl
error: File not found: /builddir/build/BUILDROOT/openmpi-4.0.2-4.fc32.arm/usr/lib/openmpi/share/openmpi/mca-btl-openib-device-params.ini

Investigating.

Comment 6 Dominik 'Rathann' Mierzejewski 2019-12-11 14:03:07 UTC
Looks like that part of openmpi only gets build when there's rdma support available, so I've just excluded the file where applicable and built.


Note You need to log in before you can comment on or make changes to this bug.