Bug 1780813 - hwloc-devel has a broken dep on rdma-core-devel on arm
Summary: hwloc-devel has a broken dep on rdma-core-devel on arm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwloc
Version: rawhide
Hardware: armhfp
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jiri Hladky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ARM 1780584
TreeView+ depends on / blocked
 
Reported: 2019-12-07 06:03 UTC by Orion Poplawski
Modified: 2019-12-10 02:44 UTC (History)
3 users (show)

Fixed In Version: hwloc-2.0.4-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-10 02:44:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2019-12-07 06:03:39 UTC
Description of problem:

DEBUG util.py:596:  Error: 
DEBUG util.py:596:   Problem: conflicting requests
DEBUG util.py:596:    - nothing provides rdma-core-devel(armv7hl-32) needed by hwloc-devel-2.0.4-1.fc32.armv7hl

rdma-core-26.1-1.fc32

Comment 1 Honggang LI 2019-12-09 13:01:27 UTC
When we replace package 'rdma' with package 'rdma-core', fedora package building
system did not build package for arm32 platform. Please see 

https://bugzilla.redhat.com/show_bug.cgi?id=1484155

rdma-core-16.2-1.fc28 is the first release built package for arm32. It is a mistake.

https://koji.fedoraproject.org/koji/packageinfo?packageID=23665

Now, we fixed this by excluding arm32.


Note You need to log in before you can comment on or make changes to this bug.