Bug 178071 - gnome-terminal crashes on startup
gnome-terminal crashes on startup
Status: CLOSED DUPLICATE of bug 178015
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 178087 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 13:03 EST by Alastair Neil
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alastair Neil 2006-01-17 13:03:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
after todays update gnome-terminal crashes on startup

Version-Release number of selected component (if applicable):
gnome-terminal-2.13.2-1

How reproducible:
Always

Steps to Reproduce:
1.login
2.
3.
  

Actual Results:  gnome-terminal maps some windows then dies

Expected Results:  terminal windows should remain available

Additional info:

Was working fine on a clean install of FC5test2 prior to update 

possibly related: gnome-volume-manager also dies on login (I've seen the bug reports) as does gnome-panel.  Gnome-panel seems to manage to get itself back on its feet after several attempts.

gdb trace:
** (gnome-terminal:3083): WARNING **: Error compiling regular expression "\<(file:///(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) 
,\"])?".
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
Detaching after fork from child process 3087.
Detaching after fork from child process 3088.
[New Thread -1215173728 (LWP 3089)]

(gnome-terminal:3083): GLib-GObject-WARNING **: invalid cast from `GtkEventBox' to `GtkLabel'

Gtk-CRITICAL **: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread -1209018704 (LWP 3083)]
0x0057db89 in g_logv () from /usr/lib/libglib-2.0.so.0
(gdb) bt
#0  0x0057db89 in g_logv () from /usr/lib/libglib-2.0.so.0
#1  0x0057de47 in g_log () from /usr/lib/libglib-2.0.so.0
#2  0x0057df15 in g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
#3  0x010520f5 in gtk_label_set_text () from /usr/lib/libgtk-x11-2.0.so.0
#4  0x080730d5 in ?? ()
#5  0x00dd98b8 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#6  0x00dccdba in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#7  0x00dddf78 in g_signal_override_class_closure () from /usr/lib/libgobject-2.0.so.0
#8  0x00ddf3f2 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#9  0x00ddf695 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#10 0x08068dfc in ?? ()
#11 0x0806a391 in ?? ()
#12 0x0806b210 in ?? ()
#13 0x00dd98b8 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#14 0x00dccdba in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#15 0x00dddf78 in g_signal_override_class_closure () from /usr/lib/libgobject-2.0.so.0
#16 0x00ddf3f2 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x00de073f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#18 0x002f384b in vte_terminal_erase_binding_get_type () from /usr/lib/libvte.so.4
#19 0x002f3923 in vte_terminal_erase_binding_get_type () from /usr/lib/libvte.so.4
#20 0x002fc5de in vte_terminal_copy_clipboard () from /usr/lib/libvte.so.4
#21 0x002fc7b0 in vte_terminal_copy_clipboard () from /usr/lib/libvte.so.4
#22 0x005760f0 in g_source_get_current_time () from /usr/lib/libglib-2.0.so.0
#23 0x00575a43 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0x00578a83 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#25 0x00578e2c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#26 0x01061fec in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x0805ee99 in ?? ()
#28 0x026776b4 in __libc_start_main () from /lib/libc.so.6
#29 0x08054641 in ?? ()
(gdb)
Comment 1 Alastair Neil 2006-01-17 14:31:11 EST
*** Bug 178087 has been marked as a duplicate of this bug. ***
Comment 2 Need Real Name 2006-01-18 06:44:23 EST
Dupe of bug 178015?
Comment 3 Jeremy Fitzhardinge 2006-01-18 13:06:03 EST
(In reply to comment #2)
> Dupe of bug 178015?

I think so.
Comment 4 Rahul Sundaram 2006-02-20 06:25:12 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 5 Behdad Esfahbod 2006-07-27 17:15:14 EDT

*** This bug has been marked as a duplicate of 178015 ***

Note You need to log in before you can comment on or make changes to this bug.