Bug 1781188 - Error in topology if knative service created via CLI
Summary: Error in topology if knative service created via CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1781193
TreeView+ depends on / blocked
 
Reported: 2019-12-09 13:55 UTC by Karthik Jeeyar
Modified: 2020-05-13 21:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The checks was not enough to handle the knative workload created from the cli Consequence: Insufficient checks resultted in white screen error in UI, when a knative is created via CLI Fix: Added sufficient checks to handle the workloads created via CLI Result: Does not the UI if there is any workload created from CLI
Clone Of:
: 1781193 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:54:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3726 'None' closed Bug 1781188: fix(knative-service): knative service created via cli 2020-04-20 09:31:19 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:54:19 UTC

Description Karthik Jeeyar 2019-12-09 13:55:25 UTC
Description of problem:


Error in topology if knative service created via CLI. The error says `can't read traffic of undefined.`

Steps to reproduce:

1. Open topology view select a project
2. Via CLI create a kn service in same projectActual results:

Actual results
It throws an error in the user is in the topology page and creates a knative service via CLI

Expected results:
It should not throw error if knative service is created via CLI

Comment 1 Gajanan More 2020-03-02 12:15:02 UTC
https://issues.redhat.com/browse/ODC-2516 verified by Sanket Pathak

Comment 4 errata-xmlrpc 2020-05-13 21:54:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.