Bug 1781193 - Error in topology if knative service created via CLI
Summary: Error in topology if knative service created via CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: All
OS: All
high
high
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1781188
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 14:17 UTC by Karthik Jeeyar
Modified: 2020-01-23 11:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1781188
Environment:
Last Closed: 2020-01-23 11:18:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error in topology if knative service created via CLI (245.94 KB, image/png)
2020-01-07 21:26 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3769 None closed [release-4.3] Bug 1781193: fix(knative-service): knative service created via cli 2020-02-11 10:43:38 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:41 UTC

Description Karthik Jeeyar 2019-12-09 14:17:39 UTC
+++ This bug was initially created as a clone of Bug #1781188 +++

Description of problem:


Error in topology if knative service created via CLI. The error says `can't read traffic of undefined.`

Steps to reproduce:

1. Open topology view select a project
2. Via CLI create a kn service in same projectActual results:

Actual results
It throws an error in the user is in the topology page and creates a knative service via CLI

Expected results:
It should not throw error if knative service is created via CLI

Comment 2 Ruchir Garg 2020-01-07 09:57:05 UTC
Assigning defect to Gajanan More for verification.

Comment 3 spathak@redhat.com 2020-01-07 21:25:01 UTC
Verified on build version:4.3.0-0.ci-2020-01-06-064249

Comment 4 spathak@redhat.com 2020-01-07 21:26:20 UTC
Created attachment 1650513 [details]
Error in topology if knative service created via CLI

Comment 6 errata-xmlrpc 2020-01-23 11:18:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.