Bug 1781499 - metering-ocp operator pulls the image via tag instead of digest in OLM package manifest.
Summary: metering-ocp operator pulls the image via tag instead of digest in OLM packag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: tflannag
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On: 1782237
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-10 07:14 UTC by Jason Shepherd
Modified: 2020-02-12 12:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1782237 (view as bug list)
Environment:
Last Closed: 2020-02-12 12:16:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-metering pull 1069 None closed Bug 1781499: Fix the invalid tag used in the release-4.2 CSV's container image field. 2020-07-01 13:36:23 UTC
Red Hat Product Errata RHBA-2020:0395 None None None 2020-02-12 12:16:42 UTC

Description Jason Shepherd 2019-12-10 07:14:50 UTC
Description of problem:

The metering operator doesn't use a sha256 digest for it's containerImage in the OLM package manifests.

Version-Release number of selected component (if applicable):

$ oc version
Client Version: openshift-clients-4.2.2-201910250432-4-g4ac90784
Server Version: 4.2.10
Kubernetes Version: v1.14.6+17b1cc6

How reproducible:

$ oc get packagemanifest/metering-ocp -n openshift-marketplace -o=jsonpath='{.metadata.name}{"\t"}{range .status.channels[*]}{.currentCSV}{"\t"}{.currentCSVDesc.annotations.containerImage}{"\n"}{end}'


Actual results:

metering-ocp	metering-operator.4.2.9-201911261133	quay.io/openshift/origin-metering-ansible-operator:latest


Expected results:

metering-ocp	metering-operator.4.2.9-201911261133	quay.io/openshift/origin-metering-ansible-operator@sha256:<blah>


Additional info:

http://post-office.corp.redhat.com/archives/openshift-sme/2019-October/msg01602.html

Comment 2 Peter Ruan 2020-01-15 02:08:37 UTC
pruan@MacBook-Pro ~/workspace/v3-testfiles/metering/rollup_reports (master)$ oc get packagemanifest/metering-ocp -n openshift-marketplace -o=jsonpath='{.metadata.name}{"\t"}{range .status.channels[*]}{.currentCSV}{"\t"}{.currentCSVDesc.annotations.containerImage}{"\n"}{end}'
metering-ocp	metering-operator.4.2.15-202001140748	image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-ansible-operator@sha256:bdb0bb39032789bbe2a8587b28e040215805be025b436b72e92a875f513a8194
metering-operator.4.3.0-202001081344	image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-ansible-operator@sha256:8f0c4cb8df57101001c8849f6a9aaba8817550baef384c0413f8ae0689a33f9b
metering-operator.4.4.0-202001082257	image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-ansible-operator@sha256:75c32ed182a799ac52e1a5ef50b582b4a7880bc11d90b2e73f29f9734a1236a5

Comment 3 Peter Ruan 2020-01-15 03:35:40 UTC
putting this back to ASSIGNED, I used the wrong branch earlier.

oc get packagemanifest/metering-ocp -n openshift-marketplace -o=jsonpath='{.metadata.name}{"\t"}{range .status.channels[*]}{.currentCSV}{"\t"}{.currentCSVDesc.annotations.containerImage}{"\n"}{end}'
metering-ocp	metering-operator.4.2.14-202001061701	quay.io/openshift/origin-metering-ansible-operator:latest

Comment 5 Peter Ruan 2020-01-29 22:24:29 UTC
Verified with  payload: 4.2.0-0.nightly-2020-01-29-160359 and able to install metering using the OLM from web

containerStatuses:
  - containerID: cri-o://1002bb5a21a789a9f91f2c929f743be0e09819d7eb95fef37cf16a042b6ae55a
    image: registry.redhat.io/openshift4/ose-metering-reporting-operator@sha256:4354d1399544d1b13e35c8219600b1375bd2bad32cb9e4f238e4a2632a64dc53
    imageID: registry.redhat.io/openshift4/ose-metering-reporting-operator@sha256:4354d1399544d1b13e35c8219600b1375bd2bad32cb9e4f238e4a2632a64dc53
    lastState: {}
    name: reporting-operator
    ready: true
    restartCount: 0
    state:
      running:
        startedAt: "2020-01-29T22:04:18Z"

Comment 7 errata-xmlrpc 2020-02-12 12:16:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0395


Note You need to log in before you can comment on or make changes to this bug.