Bug 1782237 - metering-ocp operator pulls the image via tag instead of digest in OLM package manifest.
Summary: metering-ocp operator pulls the image via tag instead of digest in OLM packag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: tflannag
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On: 1782247
Blocks: 1781499
TreeView+ depends on / blocked
 
Reported: 2019-12-11 13:42 UTC by tflannag
Modified: 2020-01-23 11:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The `containerImage` field in the metering-operator CSV bundle referenced an image tag that was not listed in the "image-refrences" file that ART uses for substitution purposes. Consequence: ART wasn't able to properly substitute the origin image listed in the `containerImage field` with the associated image-registry repository and sha256 tag Fix: Replace the image tag "latest" with "release-4.3", which is what was defined in the "image-references" file. Result: ART was able to successfully substitute the metering-oeprator container image.
Clone Of: 1781499
: 1782247 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:18:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-metering pull 1059 None closed Bug 1782237: Fix the invalid tag used in the CSV container image field. 2020-09-15 11:06:08 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:19:15 UTC

Description tflannag 2019-12-11 13:42:30 UTC
+++ This bug was initially created as a clone of Bug #1781499 +++

Description of problem:

The metering operator doesn't use a sha256 digest for it's containerImage in the OLM package manifests.

Version-Release number of selected component (if applicable):

$ oc version
Client Version: openshift-clients-4.2.2-201910250432-4-g4ac90784
Server Version: 4.2.10
Kubernetes Version: v1.14.6+17b1cc6

How reproducible:

$ oc get packagemanifest/metering-ocp -n openshift-marketplace -o=jsonpath='{.metadata.name}{"\t"}{range .status.channels[*]}{.currentCSV}{"\t"}{.currentCSVDesc.annotations.containerImage}{"\n"}{end}'


Actual results:

metering-ocp	metering-operator.4.2.9-201911261133	quay.io/openshift/origin-metering-ansible-operator:latest


Expected results:

metering-ocp	metering-operator.4.2.9-201911261133	quay.io/openshift/origin-metering-ansible-operator@sha256:<blah>


Additional info:

http://post-office.corp.redhat.com/archives/openshift-sme/2019-October/msg01602.html

Comment 2 Peter Ruan 2020-01-03 01:32:50 UTC
pruan@MacBook-Pro ~/workspace/private (master●●)$ oc get packagemanifest/metering-ocp -n openshift-marketplace -o=jsonpath='{.metadata.name}{"\t"}{range .status.channels[*]}{.currentCSV}{"\t"}{.currentCSVDesc.annotations.containerImage}{"\n"}{end}'
metering-ocp	metering-operator.4.2.13-201912230557	quay.io/openshift/origin-metering-ansible-operator:latest
metering-operator.4.3.0-201912270552	image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-ansible-operator@sha256:2153df196045b698fe0b52dba81d321482b0a2d95b49fe1577ff2dd8b1828e80
metering-operator.4.4.0-202001012223	image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-ansible-operator@sha256:2d40107f49371660d7df6a78fa0fc7783d04e1dd589f4b690fcbf8e018ca31e9

Comment 4 errata-xmlrpc 2020-01-23 11:18:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.