Bug 178172 - ooo won't focus when opening a new file and asking about macros
ooo won't focus when opening a new file and asking about macros
Status: CLOSED DUPLICATE of bug 181491
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 04:29 EST by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 05:26:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xls with macro (13.00 KB, application/octet-stream)
2006-02-13 14:19 EST, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2006-01-18 04:29:49 EST
When you double-click an Excel document in Nautilus with OOo already started,
OOo opens it and window focus is switched to OOo, which is good behaviour.

If the Excel has macros, OOo will ask to enable macros or not, but the end-user
doesn't see this as the OOo window won't get focus in this case. 
The end-user will  probably double-click the file again and ask why doesn't it open.

Please fix OOo to get window focus in this case.
Comment 1 Caolan McNamara 2006-02-09 08:03:25 EST
Can you attach one of those documents that have macros ?
Comment 2 Marius Andreiana 2006-02-13 14:19:25 EST
Created attachment 124574 [details]
.xls with macro
Comment 3 Marius Andreiana 2006-02-13 14:21:36 EST
Note that I switched to upstream ooo meanwhile and it doesn't have this minor bug.
Comment 4 Caolan McNamara 2006-02-13 14:25:23 EST
true, but it has this opposite one instead
http://qa.openoffice.org/issues/show_bug.cgi?id=19976 instead where it pops to
the front regardless of whether that's desirable or not
Comment 5 Caolan McNamara 2006-02-23 05:26:47 EST

*** This bug has been marked as a duplicate of 181491 ***

Note You need to log in before you can comment on or make changes to this bug.