Bug 1782434 - VM created from VM Template disk does not fill the disk page
Summary: VM created from VM Template disk does not fill the disk page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Tomas Jelinek
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1782119
TreeView+ depends on / blocked
 
Reported: 2019-12-11 16:10 UTC by Filip Krepinsky
Modified: 2020-05-13 21:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the disk configuration of vm template is ignored on vm wizard's disk page Consequence: User needs to manually configure the disks even if using a template Fix: the wizard now correctly uses the templates' disk configuration Result: the user can use the configuration from the template without the need to manually configure it
Clone Of: 1782119
Environment:
Last Closed: 2020-05-13 21:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:54:47 UTC

Description Filip Krepinsky 2019-12-11 16:10:50 UTC
+++ This bug was initially created as a clone of Bug #1782119 +++

Description of problem:
Create a template by using disk as the provision source and use it in VM wizard, the disk page is not filled at the template does, it still need to add disk manually.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-04-054458

How reproducible:
100%

Steps to Reproduce:
1. Create a template by using disk as the provision source
2. Create a VM by using the template
3. Click "Review and create" on the first page

Actual results:
It fails because no bootable disk is found.

Expected results:
The vm is created.

Additional info:

--- Additional comment from Guohua Ouyang on 2019-12-11 08:29:44 UTC ---

Comment 1 Filip Krepinsky 2019-12-11 16:13:08 UTC
This was already fixed for 4.4 as a part of https://bugzilla.redhat.com/show_bug.cgi?id=1779116

Comment 4 Guohua Ouyang 2020-02-18 08:42:47 UTC
verified on 4.4.0-0.nightly-2020-02-10-111955

Comment 6 errata-xmlrpc 2020-05-13 21:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.