Bug 178291 - RAID0 (md) partitions not detected at install time
Summary: RAID0 (md) partitions not detected at install time
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 178396 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-01-19 06:21 UTC by Al O
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 22:40:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Al O 2006-01-19 06:21:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051205 Fedora/1.5-1 Firefox/1.5

Description of problem:
I tried a FC5test2 install on a spare disk on a test machine. I have other two disks that have two RAID0 partitions and one RAID1 (md).
After choosing a custom partition, the RAID0 partitions appear as "foreign". In case I would try an upgrade, none of the partitions would be available.
I suspect anaconda is not creating md devices for RAID0 partition, because I tried a rescue boot with FC5test2 DVD and it would not detect RAID0 partitions, just the RAID1 partition.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot FC5test2 DVD
2. Choose custom partitioning

  

Actual Results:  RAID0 partitions are listed as "foreign"

Expected Results:  md devices should be created and RAID0 partitions listed as ext3.

Additional info:

I had the simillar problem with FC4, using the same partitioning setup. I filled a bug report, which I can't find now in bugzilla. At that time it was suggested that something was wrong in the kernel as it was supposed to detect the RAID0 partitions and that the later kernel should be OK. But after installing FC5test2 on the spare disk, I could mount and access all RAID0 partitions, all md devices were present.

Comment 1 Chris Lumens 2006-01-23 18:54:08 UTC
*** Bug 178396 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2006-02-06 22:22:05 UTC
After you get to the upgrade vs. install screen or go to try to make partitions,
press ctrl-alt-f3 to get to the terminal.  Do you see a message like the following:

ERROR : couldn't get chunksize of md0: bad md magic on device

Comment 3 Jeremy Katz 2006-02-06 22:40:19 UTC
Should be fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.