Bug 1783163 - Normal user can't see Samples, Snippets tab in YAML sidebar
Summary: Normal user can't see Samples, Snippets tab in YAML sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1785492
TreeView+ depends on / blocked
 
Reported: 2019-12-13 07:30 UTC by Yadan Pei
Modified: 2020-05-13 21:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, only cluster administrators could see example YAML templates created using the ConsoleYAMLSample resource in console YAML editor. The problem has been fixed, and now all users can see these templates.
Clone Of:
: 1785492 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:55:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 369 None closed Bug 1783163: fix RBAC for ConsoleYAMLSample 2020-03-24 21:46:48 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:55:14 UTC

Description Yadan Pei 2019-12-13 07:30:11 UTC
Description of problem:
Normal user don't have the ability to view Samples, Snippets tab in YAML sidebar

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-12-155629

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user create ConsoleYAMLSample instances
$ oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/customresource/console-yaml-sample.yaml
2. normal user login to console, goes to Workloads -> Jobs page -> Create Jobs
3. YAML sidebar only have Schema, no Samples tab
 
Actual results:
3. No Samples tab for normal user and it reports forbidden error
GET https://<console_route>/api/kubernetes/apis/console.openshift.io/v1/consoleyamlsamples?limit=250 403 (Forbidden)

Expected results:
3. Normal user should have the ability to view Samples

Additional info:

Comment 1 Stephen Cuppett 2019-12-19 18:47:29 UTC
Moving this to our active development branch (4.4.0) for Target. Fixes, if any, which require backporting to earlier releases will result in cloned BZs for those releases.

Comment 2 Yadan Pei 2019-12-20 02:34:56 UTC
Thank you Stephen, cloned for 4.3

Comment 4 Yadan Pei 2020-01-13 02:53:45 UTC
Now normal user have access to Snippets tab in YAML sidebar 

Verified on     4.4.0-0.nightly-2020-01-12-221811

Comment 6 errata-xmlrpc 2020-05-13 21:55:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.