Bug 1785492 - Normal user can't see Samples, Snippets tab in YAML sidebar
Summary: Normal user can't see Samples, Snippets tab in YAML sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1783163
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-20 02:34 UTC by Yadan Pei
Modified: 2020-02-19 05:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1783163
Environment:
Last Closed: 2020-02-19 05:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 372 None closed [release-4.3] Bug 1785492: fix RBAC for ConsoleYAMLSample 2020-02-13 20:56:56 UTC
Red Hat Product Errata RHBA-2020:0492 None None None 2020-02-19 05:40:03 UTC

Description Yadan Pei 2019-12-20 02:34:26 UTC
+++ This bug was initially created as a clone of Bug #1783163 +++

Description of problem:
Normal user don't have the ability to view Samples, Snippets tab in YAML sidebar

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-12-155629

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user create ConsoleYAMLSample instances
$ oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/customresource/console-yaml-sample.yaml
2. normal user login to console, goes to Workloads -> Jobs page -> Create Jobs
3. YAML sidebar only have Schema, no Samples tab
 
Actual results:
3. No Samples tab for normal user and it reports forbidden error
GET https://<console_route>/api/kubernetes/apis/console.openshift.io/v1/consoleyamlsamples?limit=250 403 (Forbidden)

Expected results:
3. Normal user should have the ability to view Samples

Additional info:

--- Additional comment from Stephen Cuppett on 2019-12-20 02:47:29 CST ---

Moving this to our active development branch (4.4.0) for Target. Fixes, if any, which require backporting to earlier releases will result in cloned BZs for those releases.

Comment 3 Yadan Pei 2020-02-06 06:11:26 UTC
Follow the exact steps in 'Steps to reproduce' now normal user can view Samples/Snippets sidebar
Verified on 4.3.0-0.nightly-2020-02-05-220314

Comment 5 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492


Note You need to log in before you can comment on or make changes to this bug.