Bug 17834 - gdm and gnome logout halt inconsistent
gdm and gnome logout halt inconsistent
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
: 18774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-25 17:13 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 10:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-09-25 17:13:07 EDT
Selecting "halt" from gdm results in a "poweroff"  However, selecting
"halt" on the gnome logout panel results in a halt and NO poweroff.
Comment 1 Pierre Thonne 2000-10-05 15:23:08 EDT
II've the same bug but I check further. Here are the result.

I use two laptops : a Dell latitude Cpi a366xt and a FIC DesignNote 3500
(Pentium 120Mhz).
I've made tests on the two. The two machines do same things except that the Dell
doesn't reboot when selecting a reboot in gdm, or after a 'reboot or shutdown
-r' command.

GDM menu :
- halt in the gdm menu gives a shutdown and a power off
- reboot in the gdm menu gives a shutdown and no reboot; the last 2 lines on the
screen are 
"stopping all md devices"
"system halted"

In console mode or in a xterm, the 'reboot' command power off the machine.
A 'halt' command stop the system but doesn't power off. The last 2 lines on the
screen are 
"stopping all md devices"
"system halted"
When pressing "ctrl-alt-del", the message "stopping all md devices" appears
again and then the machine power off.

Cordially,

Pierre Thonne
Brussels
Comment 2 David Woodhouse 2000-10-13 08:59:34 EDT
*** Bug 18774 has been marked as a duplicate of this bug. ***
Comment 3 dkaplan 2000-11-26 15:18:08 EST
Same problem, this time with a gateway laptop
Comment 4 weltyj 2000-11-28 09:41:24 EST
Same problem with a compaq deskpro ep (350 Mhz Pentium II).  Previous versions
of redhat worked just fine on reboot/halt..
Comment 5 Havoc Pennington 2000-11-28 10:26:30 EST
This bug is because someone changed "shutdown -h" to not do a poweroff. Then
gdm was updated to reflect the change and the panel was not. Anyway, will get
fixed in the next version.
Comment 6 Elliot Lee 2001-01-30 14:18:02 EST
gnome-session currently calls /usr/bin/poweroff, so it should theoretically Work
Fine. The rebootfix patch makes this change (someone has edited the rebootfix
patch since 7.0).

Note You need to log in before you can comment on or make changes to this bug.