Bug 1783651 - 404 Not Found when one opens install plan to approve [openshift-4.4]
Summary: 404 Not Found when one opens install plan to approve [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1803777 1807307 (view as bug list)
Depends On:
Blocks: 1788246
TreeView+ depends on / blocked
 
Reported: 2019-12-14 12:03 UTC by Irina Gulina
Modified: 2020-05-13 21:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the link to the InstallPlan resource from the Subscription overview was broken. This made it difficult to approve InstallPlans. The link now works correctly.
Clone Of:
: 1788246 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:55:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 for comment #0 (61.21 KB, image/png)
2019-12-14 12:03 UTC, Irina Gulina
no flags Details
screenshot 2 for comment #0 (28.73 KB, image/png)
2019-12-14 12:05 UTC, Irina Gulina
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3873 None closed Bug 1783651: Fix "requires approval" install plan link 2020-07-10 15:16:27 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:55:23 UTC

Description Irina Gulina 2019-12-14 12:03:48 UTC
Created attachment 1645156 [details]
screenshot 1 for comment #0

Description of problem:
In Subscription Overview tab, when one clicks URL titled '1 requires approval' and linked to https://console-openshift-console.apps.working.oc4/k8s/ns/openshift-cnv/installplans/<name of a given ip to approve>, 404 Not Found window is shown

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-12-021332

How reproducible:
always

Steps to Reproduce:
1. Install operator n-1 version from n channel, so it can be updated. Set Subscription to Manual
2. Click '1 requires approval' in 'Subscription' tab

Actual results:
404 Not Found. See the screenshots attached.

Expected results:
no 404

Additional info:
in CLI:
>> oc get ip -n openshift-cnv
NAME            CSV                                       APPROVAL   APPROVED
install-g76rv   kubevirt-hyperconverged-operator.v2.1.0   Manual     true
install-hh55s   kubevirt-hyperconverged-operator.v2.2.0   Manual     false
>> oc describe ip install-hh55s -n openshift-cnv | less
Name:         install-hh55s
Namespace:    openshift-cnv
Labels:       <none>
Annotations:  <none>
API Version:  operators.coreos.com/v1alpha1
Kind:         InstallPlan
Metadata:
  Creation Timestamp:  2019-12-14T10:47:49Z
  Generate Name:       install-
  Generation:          1
  Owner References:
    API Version:           operators.coreos.com/v1alpha1
    Block Owner Deletion:  false
    Controller:            false
    Kind:                  Subscription
    Name:                  hco-operatorhub
    UID:                   a53409c7-b970-4b8b-911e-e426dff09c45
  Resource Version:        1121115
  Self Link:               /apis/operators.coreos.com/v1alpha1/namespaces/openshift-cnv/installplans/install-hh55s
  UID:                     2c96d84e-24f6-437e-8737-e9842d0cbd92
Spec:
  Approval:  Manual
  Approved:  false
  Cluster Service Version Names:
    kubevirt-hyperconverged-operator.v2.2.0
Status:
  Catalog Sources:
    hco-catalogsource-config
  Phase:  RequiresApproval
  Plan:
<...>

Comment 1 Irina Gulina 2019-12-14 12:05:30 UTC
Created attachment 1645157 [details]
screenshot 2 for comment #0

Notice URL address in this screenshot, and ip name from CLI logs in comment #0

Comment 2 Irina Gulina 2019-12-14 16:33:28 UTC
Actually, there is no need to have two channels. Just install operator with one channel, and set Approval to Manual before clicking Subscribe. That 404 Not Found will be there.

Comment 4 shahan 2020-02-05 04:13:12 UTC
Install operator, set Subscription to Manual. click '1 requires approval' goes to normal page.
the url is : https://c**/k8s/ns/default/operators.coreos.com~v1alpha1~InstallPlan/install-jhwgk
4.4.0-0.ci-2020-02-05-023531

Comment 5 Samuel Padgett 2020-02-18 17:17:53 UTC
*** Bug 1803777 has been marked as a duplicate of this bug. ***

Comment 6 Samuel Padgett 2020-03-06 18:56:25 UTC
*** Bug 1807307 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2020-05-13 21:55:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.