Bug 1788246 - 404 Not Found when one opens install plan to approve [openshift-4.3]
Summary: 404 Not Found when one opens install plan to approve [openshift-4.3]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Samuel Padgett
QA Contact: shahan
URL:
Whiteboard:
Depends On: 1783651
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-06 19:53 UTC by Samuel Padgett
Modified: 2020-03-10 23:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1783651
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4170 None closed [release-4.3] Bug 1788246: Fix "requires approval" install plan link 2020-07-10 15:16:16 UTC
Red Hat Product Errata RHBA-2020:0676 None None None 2020-03-10 23:53:09 UTC

Internal Links: 1797861

Description Samuel Padgett 2020-01-06 19:53:23 UTC
+++ This bug was initially created as a clone of Bug #1783651 +++

Description of problem:
In Subscription Overview tab, when one clicks URL titled '1 requires approval' and linked to https://console-openshift-console.apps.working.oc4/k8s/ns/openshift-cnv/installplans/<name of a given ip to approve>, 404 Not Found window is shown

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-12-021332

How reproducible:
always

Steps to Reproduce:
1. Install operator n-1 version from n channel, so it can be updated. Set Subscription to Manual
2. Click '1 requires approval' in 'Subscription' tab

Actual results:
404 Not Found. See the screenshots attached.

Expected results:
no 404

Additional info:
in CLI:
>> oc get ip -n openshift-cnv
NAME            CSV                                       APPROVAL   APPROVED
install-g76rv   kubevirt-hyperconverged-operator.v2.1.0   Manual     true
install-hh55s   kubevirt-hyperconverged-operator.v2.2.0   Manual     false
>> oc describe ip install-hh55s -n openshift-cnv | less
Name:         install-hh55s
Namespace:    openshift-cnv
Labels:       <none>
Annotations:  <none>
API Version:  operators.coreos.com/v1alpha1
Kind:         InstallPlan
Metadata:
  Creation Timestamp:  2019-12-14T10:47:49Z
  Generate Name:       install-
  Generation:          1
  Owner References:
    API Version:           operators.coreos.com/v1alpha1
    Block Owner Deletion:  false
    Controller:            false
    Kind:                  Subscription
    Name:                  hco-operatorhub
    UID:                   a53409c7-b970-4b8b-911e-e426dff09c45
  Resource Version:        1121115
  Self Link:               /apis/operators.coreos.com/v1alpha1/namespaces/openshift-cnv/installplans/install-hh55s
  UID:                     2c96d84e-24f6-437e-8737-e9842d0cbd92
Spec:
  Approval:  Manual
  Approved:  false
  Cluster Service Version Names:
    kubevirt-hyperconverged-operator.v2.2.0
Status:
  Catalog Sources:
    hco-catalogsource-config
  Phase:  RequiresApproval
  Plan:
<...>

--- Additional comment from Irina Gulina on 2019-12-14 12:05:30 UTC ---

Notice URL address in this screenshot, and ip name from CLI logs in comment #0

--- Additional comment from Irina Gulina on 2019-12-14 16:33:28 UTC ---

Actually, there is no need to have two channels. Just install operator with one channel, and set Approval to Manual before clicking Subscribe. That 404 Not Found will be there.

Comment 3 shahan 2020-02-28 07:22:51 UTC
1. Install operator n-1 version from n channel, so it can be updated. Set Subscription to Manual
2. Click '1 requires approval' in 'Subscription' tab
the url is https://**/k8s/ns/hasha-pro1/operators.coreos.com~v1alpha1~InstallPlan/install-6nnvh
4.3.0-0.nightly-2020-02-27-225047

Comment 5 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.