Bug 178376 - Complains about missing libjvm.so dependecy (and other problems) when editing java based macros
Complains about missing libjvm.so dependecy (and other problems) when editing...
Status: CLOSED DUPLICATE of bug 172362
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 16:37 EST by Nils Fredrik Gjerull
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 03:57:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 172362 None None None Never

  None (edit)
Description Nils Fredrik Gjerull 2006-01-19 16:37:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When using sun jre1.4.2 as the jvm in OpenOffice I get a missing shared object file error, saying that it can't find libjvm.so, when I try to edit java based macros (e.g. when I choose Tools -> Macros -> Organize Macros -> BeanShell... from the menu)



When using jre1.5.0 as the jvm I can start the macro organizer without errors, but when I choose to edit a macro absolutely nothing happens no window pops up and no error message. I have tried to edit both BeanShell and JavaScript macros.

When using libgcj-4.0.2-8.fc4 absolutely nothing happens when I try to edit JavaScripts and when I try to edit a BeanShell macro the BeanShell window appears, but I get a long errorlisting in a window.



Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.1.1-5.1

How reproducible:
Always

Steps to Reproduce:
1. Choose a JVM (sun 1.4.2, sun 1.5.0 or jre-gjc 4.0.2)
2. Choose Tools -> Macros -> Organize Macros -> (BeanShell or JavaScript) from the menu. 
3. Try to edit a macro
  

Actual Results:  Error message or nothing happens

Expected Results:  A BeanShell or JavaScript editor window should appear.

Additional info:

Error message from sun jre1.4.2:

Error occurred during initialization of VM
Unable to load native library: libjvm.so: cannot open shared object file: No such file or directory
JavaVM: JNI_CreateJavaVM called _exit, caught by abort_handler in javavm.cxx
[Java framework] sunjavaplugin.soCan not create JavaVirtualMachine, abort handler was called.
[Java framework] sunjavaplugin.soCan not create Java Virtual Machine

Error message from libgcj-4.0.2:

Video Driver is probably i810
DESKTOP_SESSION is set to
libgcj version is libgcj-4.0.2-8.fc4
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-5.1
0x780007: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e007
0x7807cc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7cc
0xce7420:  + 0x420 (__kernel_sigreturn + 0x0)
0xbcf888: /lib/libc.so.6 + 0x29888 (abort + 0xf8)
0x1ff13b1: /usr/lib/libglib-2.0.so.0 + 0x2c3b1 (g_logv + 0x462)
0x1ff13e5: /usr/lib/libglib-2.0.so.0 + 0x2c3e5 (g_log + 0x29)
0x1ff1451: /usr/lib/libglib-2.0.so.0 + 0x2c451 (g_assert_warning + 0x6a)
0x70cae90: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x48e90 (Java_gnu_java_awt_peer_gtk_GtkToolkit_gtkInit + 0x0)
0x70ccbab: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x4abab
0x1d2fbe2: /usr/lib/libgtk-x11-2.0.so.0 + 0x10bbe2
0x1f91285: /usr/lib/libgobject-2.0.so.0 + 0x8285 (g_closure_invoke + 0x10a)
0x1f9f75b: /usr/lib/libgobject-2.0.so.0 + 0x1675b
0x1fa0c23: /usr/lib/libgobject-2.0.so.0 + 0x17c23 (g_signal_emit_valist + 0x41e)
0x1fa1223: /usr/lib/libgobject-2.0.so.0 + 0x18223 (g_signal_emit + 0x29)
0x1e0b743: /usr/lib/libgtk-x11-2.0.so.0 + 0x1e7743
0x1d2e798: /usr/lib/libgtk-x11-2.0.so.0 + 0x10a798 (gtk_main_do_event + 0x33d)
0x70c2b5f: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x40b5f (awt_event_handler + 0x2e)
0x292fdf6: /usr/lib/libgdk-x11-2.0.so.0 + 0x3bdf6
0x1fe84ce: /usr/lib/libglib-2.0.so.0 + 0x234ce (g_main_context_dispatch + 0x1dc)
0x1feb4d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
0x1feb9b8: /usr/lib/libglib-2.0.so.0 + 0x269b8 (g_main_context_iteration + 0x66)
0x1c05a51: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1aa51
0x28aa33d: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4633d (X11SalInstance::Yield(unsigned char) + 0x29)
0x1b6fba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80fba (Application::Yield() + 0x50)
0x1b6ff8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80ff8 (Application::Execute() + 0x26)
0x6ba115: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x28115 (desktop::Desktop::Main() + 0x15df)
0x1bc569: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86569
0x1bc619: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86619 (SVMain() + 0x29)
0x6b1b37: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fb37 (sal_main + 0x57)
0x6b1b83: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fb83 (main + 0x27)
0xbbad5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484e1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4e1
Comment 1 Caolan McNamara 2006-01-20 03:57:04 EST
The gcj problems are the only supportable configurations. Not found libjvm.so in
sun java 1.4.2 etc is outside of our rpms and control :-(

The gcj problem is fixed in rawhide for what's that's worth and if there is a
gcc update for fc4 it will get picked up

*** This bug has been marked as a duplicate of 172362 ***
Comment 2 Nils Fredrik Gjerull 2006-01-20 06:45:56 EST
It is strange that a sun jvm is not working with OpenOffice. Sun is a primary
sponsor behind OpenOffice. Is it possible that there are som linking issues? I
suppose OpenOffice is compiled with libgcj as the jvm when making the RPM.
Perhaps some compile time option is making OpenOffice expecting to find this
shared libary in the wrong place?

Note You need to log in before you can comment on or make changes to this bug.