Bug 17838 - xmms not closing properly
xmms not closing properly
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 17348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-25 19:36 EDT by Steven Taylor
Modified: 2014-03-16 22:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-08 00:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Taylor 2000-09-25 19:36:26 EDT
Play and mp3 with xmms, close xmms, xmms seems to go away....but does it
really....NO

when you log out of xwindows it hangs...you wait, then you get an error for
every time you ran xmms in that session.
Comment 1 sh 2000-09-29 20:25:03 EDT
I am also having the same problem, according to the xmms forum several other
people using redhat 7.0 are also having this problem where xmms will segfault
upon closure:

http://forum.xmms.org/cgi-bin/sporum/comments.cgi?op=threadlist&page=1&sid=bugreports&cid=1837&view=collapsed&display=threaded&mode=

Comment 2 Jason Costomiris 2000-09-30 09:31:36 EDT
I can confirm this as well.  If I launch xmms once and play for a bit, I see
anywhere from 2 - 15 xmms processes that remain after closing xmms.  I also
tried using the 1.2.3 version of xmms out of helix's gnome package (rebuilt from
the srpm, however), and met with the same result.
Comment 3 jiefg 2000-10-01 00:40:36 EDT
I got something similar, but with gkrellm 0.10.5 .. it just won't close by
itself.

A bug reported below lets me think that all my bugs (the one above and many
others) might be related to a beta version of glibc used by RH7.

Jeff
Comment 4 Bill Nottingham 2000-10-02 18:21:32 EDT
*** Bug 17348 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2000-10-02 18:22:26 EDT
It's segfaulting in deregister_frame_info, called
from dlclose. Ugh.
Comment 6 noa 2000-10-03 04:36:44 EDT
the xmms team has released a workaround for their HEAD version consisting of
commenting out
the calls to dlclose(). I have backported the workaround to to the xmms version
shipped with
rh7 and it solves the problem. If an glibc errata is not released in an
acceptable timeframe, i would
urge redhat to issue a xmms update with this workaround.

<a href="http://noa.tm/xmms-glibc-workaround.patch">the patch is found here</a>
Comment 7 Scott Kidder 2000-10-03 15:58:27 EDT
I encountered the same problem with the stock xmms, as well as the 1.2.3 source 

patched with 3DNow enhancement.  Baffled...

Comment 8 Chris Chabot 2000-10-04 08:05:44 EDT
Had the same problem,
Upgrading to 1.2.3 fixed this problem for me though
(rpm -ta the tar.gz, then rpm -Uvh)
Comment 9 Jason Costomiris 2000-10-04 18:21:27 EDT
There is a posting on www.xmms.org about a fix.  Someone has worked around the
bug (which appears to be in glibc2.1.92) -
http://hundremeterskogen.org/~havardk/xmms/rh7/

Resolved the issue for me.
Comment 10 Jakub Jelinek 2000-10-06 12:57:47 EDT
No, glibc updates should be available in acceptable timeframe.
There is a errata candidate glibc-2.1.94-3 which you can get from
ftp://ultra.linux.cz/private/glibc, if you help testing this out, it will
be released sooner...
Comment 11 Michael Schwendt 2000-10-08 00:05:16 EDT
Although the reason for the bug in question might have been determined already
(which is my conclusion from the earlier bug reports), I add my particular
observations:

(1) If I start xmms and exit it again without doing anything else, two processes
are not killed:

  ms       27459  8.5  6.7  8888 4244 ?        S    05:52   0:02 xmms
  ms       27460  0.0  6.7  8888 4244 ?        S    05:52   0:00 xmms

(2) If I remove the entire config directory in $HOME/.xmms and proceed as
described in (1), I get a SegFault upon exit, and I need to press CTRL+C to go
beyond the following error message:

  Segmentation fault

  You've probably found a bug in XMMS, please visit
  http://www.xmms.org/bugs and fill out a bug report.

Comment 12 Bill Nottingham 2000-10-16 13:01:10 EDT
This was fixed in the glibc errata.
Comment 13 Matt Biermann 2001-04-19 14:54:19 EDT
Looks like it's back again in Red Hat 7.1 

I'm having the same problems on an upgraded 7.0 to 7.1 box

Note You need to log in before you can comment on or make changes to this bug.