Bug 1783973 - Nightly build failing because of renamed image
Summary: Nightly build failing because of renamed image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.z
Assignee: Steven Hardy
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1778904 1783974 1784505
TreeView+ depends on / blocked
 
Reported: 2019-12-16 11:18 UTC by Alberto
Modified: 2020-05-19 16:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: machine-api-operator nightly images were failing because the name of rhcos-downloader was changed to machine-os-downloader. Consequence: machine-api-opeartor was looking for rhcos-downloader image because it is one of the images that the machine-api-operator needed to load. Fix: Fixed the refence to the image within the machine-api-operator. It now looks for machine-os-downloader instead. Result: machine-api-operator nightly build is passing all automated tests because it now references the correct image.
Clone Of:
: 1783974 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:55:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2821 None closed Bug 1783973: Rename rhcos-downloader to machine-os-downloader 2020-09-03 23:38:04 UTC
Github openshift ironic-rhcos-downloader pull 18 None closed Bug 1783973: Trivial change to trigger build with new nametag 2020-09-03 23:38:05 UTC
Github openshift machine-api-operator pull 452 None closed bug 1783973: Update the image name for ironic-rhcos-downloader 2020-09-03 23:38:05 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:55:35 UTC

Description Alberto 2019-12-16 11:18:28 UTC
Description of problem:

Nightly build failing because of missing image
error: unable to create a release: operator "machine-api-operator" contained an invalid image-references file: no input image tag named "ironic-rhcos-downloader"

Apparently this image was silently removed?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Steven Hardy 2019-12-16 11:32:22 UTC
> Apparently this image was silently removed?

Note that the image wasn't removed, it got renamed ref https://github.com/openshift/release/pull/5976 to support OKD builds where the "rhcos" name was not appropriate.

Adding Riccardo on Cc as I thought he was taking care of the related MAO, dev-scripts and installer PRs.

Comment 2 Clayton Coleman 2019-12-17 15:48:51 UTC
Verified manually to unblock backports.

Comment 3 W. Trevor King 2019-12-18 11:18:52 UTC
Flipping back to ASSIGNED momentarily to get [1] in.

[1]: https://github.com/openshift/ironic-rhcos-downloader/pull/18

Comment 4 W. Trevor King 2019-12-18 11:35:00 UTC
also https://github.com/openshift/release/pull/6416

Comment 5 W. Trevor King 2019-12-18 19:27:20 UTC
Still waiting on [1].

[1]: https://github.com/openshift/release/pull/6416

Comment 6 sdasu 2020-03-11 13:12:35 UTC
(In reply to W. Trevor King from comment #5)
> Still waiting on [1].
> 
> [1]: https://github.com/openshift/release/pull/6416

https://github.com/openshift/release/pull/6416 has merged.

Comment 8 errata-xmlrpc 2020-05-13 21:55:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.