Bug 1783974 - Nightly build failing because of missing image
Summary: Nightly build failing because of missing image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.3.0
Assignee: sdasu
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On: 1783973
Blocks: 1784505
TreeView+ depends on / blocked
 
Reported: 2019-12-16 11:21 UTC by Alberto
Modified: 2020-01-23 11:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1783973
Environment:
Last Closed: 2020-01-23 11:19:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2846 None None None 2019-12-18 19:24:49 UTC
Github openshift ironic-rhcos-downloader pull 19 None None None 2019-12-18 11:10:22 UTC
Github openshift machine-api-operator pull 454 None None None 2019-12-17 15:49:49 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:19:49 UTC

Description Alberto 2019-12-16 11:21:13 UTC
+++ This bug was initially created as a clone of Bug #1783973 +++

Description of problem:

Nightly build failing because of missing image
error: unable to create a release: operator "machine-api-operator" contained an invalid image-references file: no input image tag named "ironic-rhcos-downloader"

Apparently this image was silently removed?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Stephen Cuppett 2019-12-17 12:49:31 UTC
Adding TestBlocker label. Test requires working nightlies at this point in the release.

Comment 3 W. Trevor King 2019-12-18 11:11:41 UTC
Needs to stay open until [1] gets cherry-picked into 4.3.

[1]: https://github.com/openshift/installer/pull/2821

Comment 4 Stephen Benjamin 2019-12-18 19:25:14 UTC
Cherry pick https://github.com/openshift/installer/pull/2846

Comment 6 Jianwei Hou 2019-12-20 07:00:58 UTC
This no longer blocks nightly builds and ocp installer. Moving to verified.

If this needs verification for IPI baremetal, please reopen.

Thanks.

Comment 8 errata-xmlrpc 2020-01-23 11:19:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.