Bug 17840 - Anaconda Traceback Errors (included)
Anaconda Traceback Errors (included)
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-25 19:47 EDT by Chris Kloiber
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-01 18:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2000-09-25 19:47:02 EDT
My hardware is as follows:

Athlon 550 (Slot-A)
FIC-SD11 motherboard
256M RAM (requires mem=256M)
Voodoo3/3000/AGP
NetGear FA310-TX
Sound Blaster 16

I get what I believe is the identical error from my other machinne, as
follows:

Athlon 800 (Socket-A, Thunderbird)
MSI6330 motherboard
256M RAM (doesn't need mem=256M)
Voodoo3/3000/AGP
Linksys LNE100-TX (ver 2.0)
SBLive! MP3

Both machines go through the install to the point of formatting the
filesystems, and the swap After that they go 'blah'.  There are two
workarounds I have found for this problem- 1) Network install (http://)
worked fine. 2) 'expert' install (in text or graphics) work fine if I do
not specify the NIC. They can be configured post install without problems.

Allowing capture of Traceback errors is a "Good Thing"(tm). Here's mine:

---8<---
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Mogens Kjaer 2000-09-26 04:43:49 EDT
I've seen the same problem, however, not selecting the NIC
in expert mode didn't help.

The debug output tells that it tries to query the free space
of /mnt/sysimage//win95 but this file doesn't exist.

I've asked for my win95 partition to be mounted as /win95
Comment 2 Michael Fulbright 2000-09-26 11:11:57 EDT
Are you trying to mount a FAT partition as /c?

Is this a partionless install or upgrade?
Comment 3 Michael Fulbright 2000-09-26 11:12:52 EDT
This looks like bug 17846.
Comment 4 Need Real Name 2000-09-26 11:19:11 EDT
the Same error for me.

I am trying to mount a NTFS partition as /nt1. I also have /nt2 and /nt3

Local variables in innermost frame:
fsystem: /mnt/sysimage//nt1
Comment 5 m-yoda 2000-09-26 13:27:10 EDT
I have exactly the same problem, install gets as far as the formating swap 
space, and crashes just after.  I will probably follow up with the output of 
the bug report
Comment 6 Matthew Lenz 2000-09-29 18:00:19 EDT
here is my input for this bug .. here's my hardware
dual p3, aic7xxx, geforce2, sda1 win98, sdb1 swap, sdb2 linux native
here is my recollection of the matter (i've had this for days.. bugzilla has 
been down or something) .. i'm probably gunna just try to install without using 
disk druid to setup the fat32 mount ..

From memory so take with a grain of salt and i'm not sure of the order of these 
screens

1. insert boot cd
2. at prompt hit enter
3. leave english selected.. click next

keyboard
-. leave english selected, select Microsoft Natural .. click next

mouse
-. leave generic - 3 button (ps/2) selected .. click next

time
-. select America/Chicago (Central)
-. select UTC to -6 Central (dont think this really matters)
-. check use daylight savings time (once again don't think it matters)
-. click next

network
-. select use dhcp, leave active at boot checked (i think that was the option) 
click next

password setup
-. leave two default options.. md5 and shadow checked.. click next

user setup
-. add root password
-. add one user account

IO/Partition setup
-. leave current settings for my old redhat install the way they are
-. /dev/sda1 -> windows fat 32 -> add /mnt/win98 moun pnt
-. /dev/sdb1 -> linux swap -> 
-. /dev/sdb2 -> linux native -> add / mount pnt
-. click next

Lilo boot
-. uncheck 'create boot floppy'
-. install lilo to MBR of /dev/sda1
-. leave linear mode checked
-. check box to set 'dos' as default parition
-. click next.

Package selection.
-. select install (dont like upgrades) .. and custom, click next
-. uncheck a bunch of packages from the list (emacs, kde, news server, etc.. )
-. check select individual packages
-. remove tetex stuff.. add a bunch of packages i wanted that were not checked
-. click next .. a few packages still checked that need tetex
-. 1. my first install try, i went back and forth until i'd found and
      unselected all the various packages that had dependancies on stuff i didnt
      want installed
   2. second install try, I just clicked the section option..something like do 
not install
      packages that have dependancies
-. click next

Install screen.
-. says its formatting the file system
-. says its formatting the swap..

BOOM

-. saved error to floppy
-. btw, i'm nearly positive this is the exact same error for both scenerios
   (hit enter to fast the first time and lost the message on reboot)

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/win98

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 7 Need Real Name 2000-09-30 00:00:41 EDT
I have tried several things, and it seems that the install works fine as long 
as you don't change any of the packages.
Comment 8 rselzler 2000-09-30 09:32:38 EDT
Same problem here, except for the name and mount point for an existing DOS
partition.
DRUID was supposed to mount it on /Win98C...  here's the relevant Traceback
(nice feature !)

SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//Win98C
Comment 9 Andrew Echols 2000-09-30 23:52:20 EDT
I have the same problem too. It looks like there are quite a few of these. The 
only thing that varies between the different reports 
is "fsystem: /mnt/sysimage//xxyy". On my box, xxyy was "dos". To me it looks 
like the fsystem has little or no effect on the bug, and is completely in the 
filenames. The thing it screws up on is:
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
and all the other things in there have "/var/tmp/anaconda-7.0.1/" in front. 
Since I'm not familiar with how anaconda works, I can't say for certain what it 
is, but I think the problem code might be something like this:
  run( installpath + "/usr/lib/anaconda/image.py" );
 ...
  run( installpath + "/usr/lib/anaconda/fstab.py" );
 ...
  run( "/usr/lib/anaconda/isys.py" );
where installpath is "/var/tmp/anaconda-7.0.1/".
If I'm right, it's a pretty easy fix, especially if it's in a script of some 
sort.
Comment 10 Andrew Echols 2000-10-01 00:38:20 EDT
Ok, so it really isn't that simple after all. (D'OH!) However, I seem to have 
found a workaround. It appears to work fine, since I've got it humming away at 
the install now. When setting up partitions with druid, I noticed it was doing 
some crazy stuff, like showing partitions where they weren't, and the most mind-
boggling thing was my hdb2 partition that read:
  mount point: /dos/swap
  size: 160
  allocation: failed
  reason: allocation successful <--- wtf?

So....I took a step back and used fdisk. After setting it all up with fdisk, 
the GUI part same back up for mount point setting. I set mount points for the 
boot and root partitions, but did *NOT* set mount points for the dos 
partitions. The partitions formatted and the install started without any 
further troubles.  Not setting it up here really isn't a problem because later 
you can just edit fstab and add in the dos partitions after it's all over.
Comment 11 Need Real Name 2000-10-01 08:56:09 EDT
Installed from both a SCSI-cd (graphical) and from another hard disk (text based) and got the same message...
After that I tried without setting any mount point for my windows disk. Still the same problem.
Comment 12 Need Real Name 2000-10-01 09:08:37 EDT
Correction, last message was a bit wrong. Only the SCSI-cd install (graphical) produced this message. 
I choosed custom and gave the windows drive a mount point.
Comment 13 Alan Cox 2000-10-01 18:45:51 EDT

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.