Bug 1784264 (internal-imagestream-fix) - No imagestreams detected when Deploy Image with "Image name from internal registry" from webconsole
Summary: No imagestreams detected when Deploy Image with "Image name from internal reg...
Keywords:
Status: CLOSED ERRATA
Alias: internal-imagestream-fix
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1806706
TreeView+ depends on / blocked
 
Reported: 2019-12-17 06:22 UTC by XiuJuan Wang
Modified: 2020-05-04 11:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Cause: Users with limited permissions is not able to pull the clusterwide imagestreams Consequence: In deploy image, Internal registry imagestreams are not shown even if there is some imagestream in the namespace. Fix: Moved the imagestream fetching logic from cluster level to namespace level Result: If the user has permisssion to few namespaces, then all the imagestreams in those namespaces will be shown to the user.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:20:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
No imagestream detected (33.00 KB, image/png)
2019-12-17 08:23 UTC, XiuJuan Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3831 None closed Bug 1784264: add namespace level imagestream fetching 2020-05-27 08:51:39 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:20:43 UTC

Description XiuJuan Wang 2019-12-17 06:22:29 UTC
Description of problem:
No imagestreams detected when Deploy Image with "Image name from internal registry" from webconsole 

Version-Release number of selected component (if applicable):
4.4.0-0.ci-2019-12-14-210519

How reproducible:
always

Steps to Reproduce:
1.Login to webconsole with common user,and create a project 
2.Create or generate an imagestream under project
$oc new-build ruby~https://github.com/openshift/ruby-hello-world.git 
$oc get is
ruby-hello-world        image-registry.openshift-image-registry.svc:5000/wxj/ruby-hello-world        latest   12 minutes ago

3.Deploy image via click "Container image" catalog, then choose "Image name from internal registry"


Actual results:
Step 3: No imagestreams detected under project when an imagestream exists.

Expected results:
Could detecte the existing imagestream.

Additional info:

Comment 1 XiuJuan Wang 2019-12-17 08:23:18 UTC
Created attachment 1645782 [details]
No imagestream detected

Comment 2 cvogt 2019-12-17 16:33:39 UTC
Related to: https://issues.redhat.com/browse/ODC-2536

Comment 4 XiuJuan Wang 2020-01-09 08:40:26 UTC
Test this issue with 4.4.0-0.nightly-2020-01-08-194939, and fixed.
Could detect the imagestream and tag under project from `Image name from internal registry`

Comment 6 errata-xmlrpc 2020-05-04 11:20:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.