Bug 1784508 - NetworkManager system loses IP address after lease time (24 hrs) expires
Summary: NetworkManager system loses IP address after lease time (24 hrs) expires
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-17 15:48 UTC by Tom Tracy
Modified: 2020-05-19 06:20 UTC (History)
16 users (show)

Fixed In Version: NetworkManager-1.22.8-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:59 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproducer script (532 bytes, application/x-shellscript)
2019-12-20 10:53 UTC, Beniamino Galvani
no flags Details
tcpdump.log.bz2 (15.48 MB, application/x-bzip)
2020-05-18 19:11 UTC, Joseph Kachuck
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:24 UTC
freedesktop.org Gitlab NetworkManager/NetworkManager-ci/-/commit/c763a45400aa36ff00e58ae801f380db07c24eec 0 None None None 2020-04-06 11:57:49 UTC

Description Tom Tracy 2019-12-17 15:48:56 UTC
Description of problem:

NetworkManager-1.22.0-0.2.el8.x86_64 system loses it's IPV4 Address after the lease time expires. 

Also not after to ping other systems or NFS mount volumes after system reboot. Takes as long as 10 minutes to reach remote hosts. Logging in is not an issue 


Version-Release number of selected component (if applicable):

NetworkManager-1.22.0-0.2.el8.x86_64

How reproducible:

After every reboot 


Steps to Reproduce:
1. Boot Machine
2. Test workload and let system stay up for 24 hrs
3. After 24 hours, systems loses it IP Address and need to access console to restart network

Actual results:

Can not log in

Expected results:

Network should stay up for longer periods 

Additional info:

Do not see this issue with NetworkManager-1.22.0-0.1.el8.x86_64 with either losing IP address or mount NFS Volumes after reboot

Here is the message from journalctl where there is a failure
Dec 17 10:34:24 perf2.perf.lab.eng.bos.redhat.com NetworkManager[1851]: <info>  [1576596864.7568] dhcp4 (eno3): state changed bound -> expire
Dec 17 10:34:24 perf2.perf.lab.eng.bos.redhat.com NetworkManager[1851]: <info>  [1576596864.9608] device (eno3): DHCPv4: 480 seconds grace period started

Comment 1 Beniamino Galvani 2019-12-20 10:53:31 UTC
Created attachment 1646789 [details]
Reproducer script

Comment 2 Beniamino Galvani 2019-12-20 13:44:46 UTC
Upstream merge request:

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/368

Comment 3 Pablo Greco 2020-03-31 14:56:48 UTC
I was also seeing this problem, and I can't replicate it anymore after updating to 1.22.8-4.el8

Comment 4 Thomas Haller 2020-03-31 15:17:20 UTC
for rhel-8.2, we will change the implementation of the default DHCP plugin.
From a systemd based DHCP client to a nettools based one.

Initially there were some issues, I believe these are all fixed in recent rhel-8.2 builds.


If you have new DHCP related issues with a recent rhel-8.2 build, please open a new bug. It very likely has different underlying causes.

Comment 8 errata-xmlrpc 2020-04-28 16:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847

Comment 11 Joseph Kachuck 2020-05-18 19:11:42 UTC
Created attachment 1689672 [details]
tcpdump.log.bz2


Note You need to log in before you can comment on or make changes to this bug.