Bug 1784755 - Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs`
Summary: Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1784756
TreeView+ depends on / blocked
 
Reported: 2019-12-18 09:25 UTC by zhou ying
Modified: 2020-05-04 11:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1784756 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:20:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 224 0 None closed Bug 1784755: set insecure-skip-tls-verify-backend flag 2020-04-22 09:56:44 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:20:58 UTC

Description zhou ying 2019-12-18 09:25:05 UTC
Description of problem:
Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs` 

Version-Release number of selected component (if applicable):
Client Version: v4.4.0


How reproducible:
Always

Steps to Reproduce:
1. `oc logs  --insecure-skip-tls-verify-backend=true  --previous=true  -f po/ovs-78jwh   -n openshift-sdn   --loglevel=9 |& tee /tmp/logs2`

Actual results:
1. Check the command logs, could not find the options of 'insecure-skip-tls-verify-backend':
I1218 15:05:22.479914   25926 round_trippers.go:423] curl -k -v -XGET  -H "Accept: application/json, */*" -H "User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format" 'https://api.xxxx:6443/api/v1/namespaces/openshift-sdn/pods/ovs-78jwh/log?follow=true&previous=true'

Expected results:
2. Should set `insecureSkipTLSVerifyBackend=true` with the command.

Additional info:

Comment 2 zhou ying 2020-01-06 05:32:02 UTC
Confirmed with latest version, the issue has fixed:

[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: ""
  compiler: gc
  gitCommit: ""
  gitTreeState: ""
  gitVersion: unknown
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

[root@dhcp-140-138 ~]# oc logs  --insecure-skip-tls-verify-backend=true  -f po/ovs-4rk8t   -n openshift-sdn   --loglevel=9 |& tee /tmp/logs2
......
I0106 11:29:13.278736    8328 round_trippers.go:423] curl -k -v -XGET  -H "Accept: application/json, */*" -H "User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format" 'https://api.qe-yinzhou.qe.devcluster.openshift.com:6443/api/v1/namespaces/openshift-sdn/pods/ovs-4rk8t/log?follow=true&insecureSkipTLSVerifyBackend=true'
......

Comment 4 errata-xmlrpc 2020-05-04 11:20:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.