Bug 1784756 - Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs`
Summary: Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1784755
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-18 09:26 UTC by zhou ying
Modified: 2020-02-25 06:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1784755
Environment:
Last Closed: 2020-02-25 06:17:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 225 None closed [release-4.3] Bug 1784756: set insecure-skip-tls-verify-backend flag 2020-02-20 16:45:06 UTC
Red Hat Product Errata RHBA-2020:0528 None None None 2020-02-25 06:18:12 UTC

Description zhou ying 2019-12-18 09:26:02 UTC
+++ This bug was initially created as a clone of Bug #1784755 +++

Description of problem:
Can't set `--insecure-skip-tls-verify-backend=true` option when use `oc logs` 

Version-Release number of selected component (if applicable):
Client Version: v4.4.0


How reproducible:
Always

Steps to Reproduce:
1. `oc logs  --insecure-skip-tls-verify-backend=true  --previous=true  -f po/ovs-78jwh   -n openshift-sdn   --loglevel=9 |& tee /tmp/logs2`

Actual results:
1. Check the command logs, could not find the options of 'insecure-skip-tls-verify-backend':
I1218 15:05:22.479914   25926 round_trippers.go:423] curl -k -v -XGET  -H "Accept: application/json, */*" -H "User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format" 'https://api.xxxx:6443/api/v1/namespaces/openshift-sdn/pods/ovs-78jwh/log?follow=true&previous=true'

Expected results:
2. Should set `insecureSkipTLSVerifyBackend=true` with the command.

Additional info:

Comment 2 zhou ying 2020-02-13 05:03:29 UTC
The issue has fixed:

[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2020-02-12T17:56:47Z"
  compiler: gc
  gitCommit: 1d7211968ceb449852d10d12eae92ed5c33d8b48
  gitTreeState: clean
  gitVersion: v4.3.2
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64

oc logs  --insecure-skip-tls-verify-backend=true  -f po/ovs-278bf  -n openshift-sdn   --loglevel=9 |& tee /tmp/logs2
...
I0213 13:01:52.806488   14209 round_trippers.go:423] curl -k -v -XGET  -H "Accept: application/json, */*" -H "User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format" 'https://api.yinzhou13.qe.devcluster.openshift.com:6443/api/v1/namespaces/openshift-sdn/pods/ovs-278bf/log?follow=true&insecureSkipTLSVerifyBackend=true'

Comment 4 errata-xmlrpc 2020-02-25 06:17:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0528


Note You need to log in before you can comment on or make changes to this bug.