Bug 1785783 - python-pycryptodomex: Remove (sub)packages from Fedora 32+: python2-pycryptodomex
Summary: python-pycryptodomex: Remove (sub)packages from Fedora 32+: python2-pycryptod...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pycryptodomex
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1761070 (view as bug list)
Depends On:
Blocks: PY2REMOVAL F31_PY2REMOVAL
TreeView+ depends on / blocked
 
Reported: 2019-12-20 23:30 UTC by Miro Hrončok
Modified: 2020-06-16 10:23 UTC (History)
8 users (show)

Fixed In Version: python-pycryptodomex-3.9.7-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-16 10:23:30 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-12-20 23:30:11 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-pycryptodomex were marked for removal:

 * python2-pycryptodomex

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-12-20 23:39:23 UTC
> if there is no objection in a week

Given the timing, I'll wait until 2020-01-08 before proceeding.

Comment 2 Petr Viktorin 2020-01-07 09:37:10 UTC
cryptodomex is covered by a FESCo exception ( https://pagure.io/fesco/issue/2266 ) as an alternative to python-crypto for python-dns's use.

It's probably my fault; I might have compiled the data used to file this bug. Sorry for that!
Miro, do you want to close this?

Comment 3 Miro Hrončok 2020-01-07 10:22:00 UTC
It is not your fault. This is entirely on me and not a mistake.

Cryptodomex has an exception, but nothing uses it (even the software that drove the exception).

Hence my logic is this: It may have a Python 2 package if needed, but it is not needed now and the package shall be removed until it is needed (if).

CCing Paul Howarth - Paul, does that make sense? Do you anticipate using cryptodomex any time soon on Python 2?

Comment 4 Paul Howarth 2020-01-07 11:04:29 UTC
Currently python-dns uses python-crypto (which I maintain but is dead upstream). The upstream of python-dns supports both python-crypto and python-pycryptodomex and prefers python-pycryptodomex but the Fedora package currently uses python-crypto. I would prefer it if python-dns switched to python-pycryptodomex so I could get rid of Python2 support in python-crypto (pull request https://src.fedoraproject.org/rpms/python-dns/pull-request/1). Hence I'd like to see python-pycryptodomex retain Python2 support unless the python-dns maintainer decides they don't want to switch to python-pycryptodomex for some reason. Unfortunately they have not responded to the pull request.

Comment 5 Miro Hrončok 2020-01-07 11:09:41 UTC
Got it, thanks.

Comment 6 Petr Viktorin 2020-05-20 20:16:46 UTC
python-dns has now switched to python-cryptography, so it should be possible to remove python2-pycryptodomex.

Comment 8 Miro Hrončok 2020-06-16 10:23:06 UTC
*** Bug 1761070 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.