Bug 1786070 - Error occurs while removing the second CD-ROM
Summary: Error occurs while removing the second CD-ROM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Tomas Jelinek
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1791346
TreeView+ depends on / blocked
 
Reported: 2019-12-23 10:07 UTC by Guohua Ouyang
Modified: 2020-05-04 11:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The removal of the second cdrom was not handled properly Consequence: If the user wanted to remove 2 cdroms, it was needed to remove one, save the dialog, open it again and delete the second one Fix: the removal of second cdrom has been corrected Result: now there is no need to close and open the cdrom dialog between removing of the cdroms.
Clone Of:
: 1791346 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:21:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
delete cdrom (50.79 KB, image/png)
2019-12-23 10:07 UTC, Guohua Ouyang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:21:47 UTC

Description Guohua Ouyang 2019-12-23 10:07:51 UTC
Created attachment 1647303 [details]
delete cdrom

Description of problem:
Add two CD-ROMs to a VM and open the editing CD-ROM page, try to remove them one by one, an error occurs while removing the second CD-ROM

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-19-050538

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-01-13 12:14:54 UTC
There is a workaround. It is possible to remove one cdrom, submit the dialog and than open it again and remove the second one. Still a bug though which has to be fixed.

Comment 2 Tomas Jelinek 2020-02-05 11:50:10 UTC
has been fixed by https://github.com/openshift/console/pull/3933
part of https://errata.devel.redhat.com/advisory/47983

Comment 4 Guohua Ouyang 2020-02-18 08:39:16 UTC
verified on 4.4.0-0.nightly-2020-02-10-111955

Comment 7 errata-xmlrpc 2020-05-04 11:21:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.