Bug 1786271 - Pods number for Daemon Set is 0 on project "Workloads" page
Summary: Pods number for Daemon Set is 0 on project "Workloads" page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Sahil Budhwar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1786272
TreeView+ depends on / blocked
 
Reported: 2019-12-24 07:20 UTC by Yanping Zhang
Modified: 2020-05-04 11:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1786272 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:21:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
daemonset (89.10 KB, image/png)
2019-12-24 07:20 UTC, Yanping Zhang
no flags Details
Pods number for Daemon Set is not 0 on project "Workloads" page (118.01 KB, image/png)
2020-02-17 18:16 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4283 None closed Bug 1786271: update the number of pods in daemon set with correct status prop 2020-06-09 09:50:21 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:22:08 UTC

Description Yanping Zhang 2019-12-24 07:20:43 UTC
Created attachment 1647459 [details]
daemonset

Description of problem:
Create daemon set in project, and all pods for daemon set are running, check daemon set under project "Workloads" tab, it shows 0/0 pods for daemon set.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-22-174103

How reproducible:
Always

Steps to Reproduce:
1.Create Daemon set in project.
2.After pods are running, check Daemon Set under "Workloads" tab on project page.
3.

Actual results:
2.It shows 0/0 pods for daemonset.

Expected results:
3. Should show 3/3 pods.(There are 3 workers, and 3 pods are running here.)

Additional info:

Comment 1 Yadan Pei 2020-01-16 08:29:59 UTC
Hi Sam,

Could you let us know why it's changed to Dev Console?  When user view project workloads at Administration perspective Home -> Projects -> Workloads, the number always show 0 of 0 pods

Also can we fix it in 4.3.0? or even 4.3.z?

Comment 2 cvogt 2020-01-20 18:28:01 UTC
Added to JIRA backlog: https://issues.redhat.com/browse/ODC-2771

Comment 3 Samuel Padgett 2020-01-20 19:07:45 UTC
(In reply to Yadan Pei from comment #1)
> 
> Could you let us know why it's changed to Dev Console?  When user view
> project workloads at Administration perspective Home -> Projects ->
> Workloads, the number always show 0 of 0 pods

This view shares code with the topology view in the dev console, and they currently own that code. (Christian, let me know if you disagree with that statement :)

A lot of pages show up in both perspectives.

I agree we need to backport to 4.3.z.

Comment 4 Yadan Pei 2020-01-21 01:36:37 UTC
Sam, really appreciate your explanation.

Comment 6 spathak@redhat.com 2020-02-17 18:14:38 UTC
Verified on CI build: 4.4.0-0.ci-2020-02-15-184748
Chrome browser: 76.0.3809.132

Comment 7 spathak@redhat.com 2020-02-17 18:16:59 UTC
Created attachment 1663579 [details]
Pods number for Daemon Set is not 0 on project "Workloads" page

Comment 9 errata-xmlrpc 2020-05-04 11:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.