Bug 1786272 - Pods number for Daemon Set is 0 on project "Workloads" page
Summary: Pods number for Daemon Set is 0 on project "Workloads" page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Sahil Budhwar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On: 1786271
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-24 07:22 UTC by Yanping Zhang
Modified: 2020-03-10 23:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1786271
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4340 None closed [release-4.3] Bug 1786272: update the number of pods in daemon set with correct status prop 2020-03-02 05:05:24 UTC
Red Hat Product Errata RHBA-2020:0676 None None None 2020-03-10 23:53:09 UTC

Description Yanping Zhang 2019-12-24 07:22:10 UTC
+++ This bug was initially created as a clone of Bug #1786271 +++

Description of problem:
Create daemon set in project, and all pods for daemon set are running, check daemon set under project "Workloads" tab, it shows 0/0 pods for daemon set.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-22-174103

How reproducible:
Always

Steps to Reproduce:
1.Create Daemon set in project.
2.After pods are running, check Daemon Set under "Workloads" tab on project page.
3.

Actual results:
2.It shows 0/0 pods for daemonset.

Expected results:
3. Should show 3/3 pods.(There are 3 workers, and 3 pods are running here.)

Additional info:

Comment 1 Andrew Ballantyne 2020-01-20 19:36:13 UTC
Jira issue: https://issues.redhat.com/browse/ODC-2679

Comment 4 Yanping Zhang 2020-03-02 06:57:39 UTC
Checked on OCP 4.3 env with payload 4.3.0-0.nightly-2020-03-01-224924, now the pods number for daemonset is correct under project "Workloads" tab.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.