Bug 17869 - Install failure on RedHat 7.0
Summary: Install failure on RedHat 7.0
Status: CLOSED DUPLICATE of bug 17886
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 19:15 UTC by m-yoda
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-09-29 15:59:43 UTC


Attachments (Terms of Use)

Description m-yoda 2000-09-26 19:15:34 UTC
My systems are as follows

Tyan S1590S Trinity 100AT MB
amd k62-450
PCI Riva TNT 16mb
Microsoft Intelimouse (PS-2)

I get the same errors on my 
Gigabyte GA-5AA MB
amd k63-400
AGP Riva TNT 16mb
Generic 3-button mouse (Serial)

The install goes well till it reaches the formating of partitions, it
croaks after the swap formating.
I have tried to install without mounting my win98 partitions and also 
without specifying the ethernet card.
I also tried to install without formating the / and /home partitions and 
the result is the same. The root partiton / and /home partitions are 
separate.
By the way this was an install not an upgrade.
I previously had installed pinstripe on both of these systems without any 
problems.

Just to make sure I got the correct iso's here are the sizes
disc1 ------- 670564352
disk2 ------- 676231168
powertools -- 614799360

I will try a network installation
thanks


---------------------------------------------------------------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//dos/c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 m-yoda 2000-09-26 19:41:52 UTC
It works!!
This time I chose not to mount any other partitions other than

swap
/
/home

the problem appeared when I tried to mount any other partitions, win98, dos, 
and other linux partitions.
I suppose I can simply mount them after install
Thanks

Comment 2 Michael Fulbright 2000-09-29 15:59:40 UTC

*** This bug has been marked as a duplicate of 17886 ***


Note You need to log in before you can comment on or make changes to this bug.