Bug 17886 - Crash if doing install and mount FATpartition too
Summary: Crash if doing install and mount FATpartition too
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 17862 17869 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 21:40 UTC by Thomas Amsler
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 19:44:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text dump file generated from RH7.0 setup in text mode (1.13 KB, patch)
2000-09-26 21:42 UTC, Thomas Amsler
no flags Details | Diff

Description Thomas Amsler 2000-09-26 21:40:29 UTC
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Thomas Amsler 2000-09-26 21:42:32 UTC
Created attachment 3569 [details]
text dump file generated from RH7.0 setup in text mode

Comment 2 Thomas Amsler 2000-09-27 00:43:59 UTC
This bug only happens when I try to add an existing Win-Fat32 partion to fstab
during the install procedure. I tried the install now without adding the mount
point for the win partion and it worked fine.

Comment 3 Michael Fulbright 2000-09-29 15:27:02 UTC
Please verify brock.

Comment 4 Michael Fulbright 2000-09-29 15:40:08 UTC
Was this an install where you were installing Red Hat Linux to a FAT partition?

Comment 5 Michael Fulbright 2000-09-29 15:59:38 UTC
*** Bug 17869 has been marked as a duplicate of this bug. ***

Comment 6 Michael Fulbright 2000-09-29 16:00:46 UTC
*** Bug 17862 has been marked as a duplicate of this bug. ***

Comment 7 Michael Fulbright 2000-09-29 16:06:46 UTC
Related to bug 17846.

Comment 8 Thomas Amsler 2000-09-29 23:47:47 UTC
I installed in in a ext2 partition.

Comment 9 Alan Cox 2000-10-01 22:42:26 UTC
*** Bug 18032 has been marked as a duplicate of this bug. ***

Comment 10 Joseph H. Schwendt II 2000-10-02 07:45:41 UTC
I had the same problem.  I have a 486 laptop and am doing an NFS custom install
from a mounted RH 7.0 CD #2.  The laptop had (and still has until formated) a
FAT16 parition on it, but the install is being done completely over the
network.  I'm at a complete stand still till this is fixed.  Any more info I can
provide, please let me know.

Comment 11 John Bollinger 2000-10-02 20:47:31 UTC
I encountered this bug (or one indistinguishably similar to it).  The system had
one FAT32 partition [Win98] as /dev/hda1, which I assigned a mount point at
installation time.  Linux was installed to several other partitions [ext2] -- 
/dev/hda1 was involved in the installation only in that I set up a mount point
for it.  I used a custom installation [via CD] and opted to select individual
packages.  The installer then crashed after formatting the relevant filesystems
but before displaying the "transferring installation image [...]" progress bar.  I
was able to perform a successful installation by EITHER not setting up a
mount point for /dev/hda1 OR by not opting to select individual packages.
I didn't try both together, but I assume that would work too.

Comment 12 Michael Fulbright 2000-10-03 16:14:04 UTC
Please verify Brent.

Comment 13 Michael Fulbright 2000-10-03 19:44:46 UTC

*** This bug has been marked as a duplicate of 18032 ***


Note You need to log in before you can comment on or make changes to this bug.