Bug 17870 - Installation aborts after CD-ROM change.
Summary: Installation aborts after CD-ROM change.
Status: CLOSED DUPLICATE of bug 18031
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 18257 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 19:21 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 16:41:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-26 19:21:07 UTC
This happens both with upgrades and installation. After
inserting CD-ROM 2, nothing happens. At all. If I eject the CD
anaconda reports the following error output:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/source/RedHat/RPMS/gcc-java-2.96-54.i386.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/gcc-java-2.96-54.i386.rpm
total: 0
self: <todo.ToDo instance at 84995d0>
h: <header object at 8ce26b0>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 84633c8>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

Comment 1 Michael Fulbright 2000-09-29 15:57:52 UTC
If you mount the second CDROM and look at it does the gcc-java-2.96-54.i386.rpm
file exist?

This really sounds like either the CD is bad, or your CDROM drive doesn't like
reading it.

Comment 2 Michael Fulbright 2000-10-03 19:10:24 UTC
Also send me  the md5 sum of the gcc-java package  and I can see if it is
corrupt.

Comment 3 Michael Fulbright 2000-10-03 19:23:47 UTC
*** Bug 18257 has been marked as a duplicate of this bug. ***

Comment 4 Need Real Name 2000-10-04 06:47:14 UTC
I tend to also believe that this is a problem with the CD-ROM. I've had problems
installing some RPM's from it manually, rpm -i simply hangs on the first
attempt, but sometimes finishes as supposed to second time I try it.

[cauda]/mnt/cdrom/RedHat/RPMS>md5sum gcc-java-2.96-54.i386.rpm 
f74841ccc92a46ddf25873615363f5b2  gcc-java-2.96-54.i386.rpm



Comment 5 Michael Fulbright 2000-10-04 16:41:23 UTC
Be sure to use the binary ftp option.

*** This bug has been marked as a duplicate of 18031 ***


Note You need to log in before you can comment on or make changes to this bug.