Bug 178708 - kernel oops in stradis_probe
kernel oops in stradis_probe
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 179075 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 12:44 EST by Kimmo Koivisto
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 16:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kernel oops recorded from serial console (25.38 KB, text/plain)
2006-01-23 12:44 EST, Kimmo Koivisto
no flags Details
output from serial console at boot (8.99 KB, text/plain)
2006-01-26 22:50 EST, John Reiser
no flags Details
screenshot from FC5 devel (215.00 KB, image/png)
2006-02-03 20:18 EST, Ronald Warsow
no flags Details

  None (edit)
Description Kimmo Koivisto 2006-01-23 12:44:04 EST
Description of problem:    
    
I have FC5t2 (updated from t1 with yum) and I have problems booting with     
kernel-2.6.15-1.1863_FC5. I cannot boot, kernel oopses when starting udev.    
   
Last working kernel was kernel-2.6.15-1.1826.2.9_FC5.   
   
Version-Release number of selected component (if applicable):    
kernel-2.6.15-1.1863_FC5    
udev-078-4   
    
How reproducible:    
Oopses in every boot with newer kernel than 2.6.15-1.1826.2.9_FC5.   
    
Steps to Reproduce:    
1. Install udev-078-4   
2. Install kernel that is newer than 2.6.15-1.1826.2.9_FC5   
3. reboot and wait until udev is started   
      
Actual results:    
Kernel oopses when udev is loaded, system does not start   
    
Expected results:    
Udev starts normally and system starts   
    
Additional info:    
See attachment
Comment 1 Kimmo Koivisto 2006-01-23 12:44:05 EST
Created attachment 123582 [details]
Kernel oops recorded from serial console
Comment 2 John Reiser 2006-01-26 22:50:32 EST
Created attachment 123765 [details]
output from serial console at boot

I see a freeze at "Starting udev:_" where the VGA cursor stops blinking, but
there is no Oops displayed, not even on serial console (serial console log
attached.)  <Alt><SysRq>T (or any other magic command) does nothing. 
kernel-2.6.15-1.1826.2.10_FC5 was the last kernel that booted OK.  Everything
since then, including the present kernel-2.6.15-1.1872_FC5, freezes at
"Starting udev:_".

initscripts-8.21-1
udev-078-7
Comment 3 Dave Jones 2006-01-29 19:49:38 EST
*** Bug 179075 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2006-02-02 16:41:26 EST
should be fixed in todays build
Comment 5 Kimmo Koivisto 2006-02-03 13:14:46 EST
Yes, kernel-2.6.15-1.1895_FC5 does start now without oops, but udev does not 
start and thus some devices such as my dvb-t card does not work. 
 
When I boot with kernel-2.6.15-1.1826.2.9_FC5, udev starts ok. 
Udev version is udev-078-8. 
 
Any way to find out what udev is doing during the startup and why it's not 
starting? 
Comment 6 Ronald Warsow 2006-02-03 20:16:08 EST
like commment...

s. attachement
Comment 7 Ronald Warsow 2006-02-03 20:18:26 EST
Created attachment 124141 [details]
screenshot from FC5 devel
Comment 8 Dave Jones 2006-02-03 22:57:04 EST
if udev is doing something incorrectly, please file a separate udev bug.
Comment 9 Ronald Warsow 2006-02-04 15:49:48 EST
seems to be fixed with 2.6.15-1.1907, but driver looks like in comment 7.
dvb-t works: catured mpegs with dvbtools !

dvb-t module is loaded, but it can't be seen, when computer starts, like in FC4 !

Note You need to log in before you can comment on or make changes to this bug.