This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 178725 - clamav-autoupdate issues with email and files
clamav-autoupdate issues with email and files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: Reopened
: 427103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 14:50 EST by Paul Wouters
Modified: 2008-05-15 09:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.93-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 09:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2006-01-23 14:50:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I noticed two things in clamav-updates

1) It executes a file in /usr/share, while share is defined according to the lsb for "Architecture-independent data", and one should be able to mount it with noexec. This is better put in a crontab entry anyway, instead of being called indirectly through crontab.

2) /etc/cron.d/clamav-update sets MAIL= to root, webmaster, postmaster and clamav,
which generates *four* emails, which is excessive. The clamav-* packages also did not create a user or alias for "clamav", so this generates a bounces on top of the other emails.

3) it takes an effort to enable updating, which i think that if people install clamav-update is what they give "permission" for to do to begin with. I think it should just work istead of having all these manual edits requires before it works.


Version-Release number of selected component (if applicable):
clamav-update-0.88-1.fc4

How reproducible:
Didn't try

Steps to Reproduce:
1. install clamav-* rpms
2. wait for cron to kick in
3.
  

Additional info:
Comment 1 Nicola Soranzo 2006-11-29 07:43:07 EST
This bug applies also to FC6.
Comment 2 Enrico Scholz 2006-11-29 08:32:19 EST
1. putting scripts into /usr/share is common practice in Fedora; I did not found
an indication in LSB that /usr/share count be mounted noexec. I do not
understand the comment about the crontab.

2. before adding these recipient, it was complained that nobody would see the
mails because mails to root would go to /dev/null. Or, do you know a better,
universal recipient which would be read on every system?

3. won't change that. It would be a bug when program connects to the internet
without explicit activation.
Comment 3 Nicola Soranzo 2006-11-29 10:24:49 EST
1. You're right about the noexec option, anyway the FHS (which is mandatory for
LSB) says that /usr/share is for Architecture-indipendent _data_ (see
http://www.pathname.com/fhs/pub/fhs-2.3.html#USRSHAREARCHITECTUREINDEPENDENTDATA ).

2. If you're a sys admin and configure your /etc/aliases, you surely change root
alias. Otherwise in a standard install webmaster and postmaster are aliased to
root, clamav bounces to root (which in this way receive 4 emails every 20 mins).
In both cases I'd leave only root, as most other cron scripts.

3. That's up to you, but yum-updatesd/puplet don't work like that.
Comment 4 Paul Wouters 2006-11-30 00:55:11 EST
1) is a real bug with LSB. not enough for me to keep this bug open.
2) anyone not having a root mail alias is choosing to have their mail go to
/dev/null. It surely beats 4 emails and a bounce for everyone. eg let the ones
who break the system on purpose have a problem, not the one who properly
configure their email setup.
3) It's your choice as package maintainer.

If you fix 2, I'd consider my bug report handled
Comment 5 Nicola Soranzo 2008-01-09 06:48:36 EST
Still applies to Fedora 8.
Comment 6 Nicola Soranzo 2008-03-31 11:51:43 EDT
*** Bug 427103 has been marked as a duplicate of this bug. ***
Comment 7 Bug Zapper 2008-05-13 22:04:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.