Bug 1787265 - FreeCAD crashes when creating a sketch
Summary: FreeCAD crashes when creating a sketch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-02 01:33 UTC by bztdlinux
Modified: 2020-01-27 11:26 UTC (History)
5 users (show)

Fixed In Version: freecad-0.18.4-5.fc30 freecad-0.18.4-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-26 01:00:31 UTC
Type: Bug


Attachments (Terms of Use)

Description bztdlinux 2020-01-02 01:33:30 UTC
Description of problem:
FreeCAD crashes when creating a sketch


Version-Release number of selected component (if applicable):
freecad-1:0.18.4-3.fc31.x86_64  

How reproducible:
Always

Actual results:

$ FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Show.TempoVis.isIn3DView error: 'NoneType' object has no attribute 'getTail'Show.TempoVis.isIn3DView error: 'NoneType' object has no attribute 'getTail'Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3c6b0) [0x7f5827f9b6b0]
#1  0x7f5827b35ecf in SoState::getElement(int) from /lib64/libCoin.so.80+0x15f
#2  0x7f5827a4ca8c in SoInt32Element::set(int, SoState*, SoNode*, int) from /lib64/libCoin.so.80+0x2c
#3  0x7f5827b89eee in SoSwitch::doAction(SoAction*) from /lib64/libCoin.so.80+0x7e
#4  0x7f582798b837 in SoAction::traverse(SoNode*) from /lib64/libCoin.so.80+0x67
#5  0x7f5827b21a38 in SoChildList::traverse(SoAction*, int, int) from /lib64/libCoin.so.80+0x168
#6  0x7f5827b6cb5c in SoGroup::doAction(SoAction*) from /lib64/libCoin.so.80+0x5c
#7  0x7f5827b8676c in SoSeparator::doAction(SoAction*) from /lib64/libCoin.so.80+0x2c
#8  0x7f582798b837 in SoAction::traverse(SoNode*) from /lib64/libCoin.so.80+0x67
#9  0x7f582799b6a4 in SoSearchAction::beginTraversal(SoNode*) from /lib64/libCoin.so.80+0x54
#10  0x7f582798bcda in SoAction::apply(SoNode*) from /lib64/libCoin.so.80+0x28a
#11  0x7f5829ef2021 in Gui::View3DInventorViewer::searchNode(SoNode*) const from /usr/lib64/freecad/lib/libFreeCADGui.so+0x61
#12  0x7f5829c6b4db in Gui::Document::getViewOfNode(SoNode*) const from /usr/lib64/freecad/lib/libFreeCADGui.so+0x7b
#13  0x7f57969f3bf2 in SketcherGui::ViewProviderSketch::getScaleFactor() from /usr/lib64/freecad/lib/SketcherGui.so+0x42
#14  0x7f5796a02a28 in SketcherGui::ViewProviderSketch::combineConstraintIcons(std::vector<SketcherGui::ViewProviderSketch::constrIconQueueItem, std::allocator<SketcherGui::ViewProviderSketch::constrIconQueueItem> >) from /usr/lib64/freecad/lib/SketcherGui.so+0x38
#15  0x7f5796a040d9 in SketcherGui::ViewProviderSketch::drawConstraintIcons() from /usr/lib64/freecad/lib/SketcherGui.so+0xea9
#16  0x7f5796a0935c in SketcherGui::ViewProviderSketch::draw(bool, bool) from /usr/lib64/freecad/lib/SketcherGui.so+0x428c
#17  0x7f5796a195e1 in SketcherGui::ViewProviderSketch::setEdit(int) from /usr/lib64/freecad/lib/SketcherGui.so+0xba1
#18  0x7f5829f168b2 in Gui::ViewProvider::startEditing(int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x42
#19  0x7f5829eefd95 in Gui::View3DInventorViewer::setEditingViewProvider(Gui::ViewProvider*, int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x35
#20  0x7f5829c6b69d in Gui::Document::setEdit(Gui::ViewProvider*, int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0xfd
#21  0x7f5829c85a2c in Gui::DocumentPy::setEdit(_object*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0xac
#22  0x7f5829c8658e in Gui::DocumentPy::staticCallback_setEdit(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x3e
#23  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x25e) [0x7f582900ba7e]
#24  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f582900bbb3]
#25  /lib64/libpython3.7m.so.1.0(+0x141c73) [0x7f582903ec73]
#26  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x55c2) [0x7f582907a182]
#27  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f582902bb40]
#28  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f582902c8d9]
#29  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f58290bc6bb]
#30  /lib64/libpython3.7m.so.1.0(+0x2006e3) [0x7f58290fd6e3]
#31  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f58290fd77d]
#32  0x7f582938be2a in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x6a
#33  0x7f5829cc9784 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x134
#34  /usr/lib64/freecad/lib/PartDesignGui.so(+0xd4700) [0x7f57970e9700]
#35  0x7f579711b905 in PartDesignGui::TaskDlgFeaturePick::~TaskDlgFeaturePick() from /usr/lib64/freecad/lib/PartDesignGui.so+0x1b5
#36  0x7f579711b9ad in PartDesignGui::TaskDlgFeaturePick::~TaskDlgFeaturePick() from /usr/lib64/freecad/lib/PartDesignGui.so+0xd
#37  0x7f5829ea6c23 in Gui::TaskView::TaskView::removeDialog() from /usr/lib64/freecad/lib/libFreeCADGui.so+0xe3
#38  0x7f5829ea7137 in Gui::TaskView::TaskView::accept() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x97
#39  0x7f58285ccecb in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x69b
#40  /lib64/libQt5Widgets.so.5(+0x30b8d6) [0x7f5828b678d6]
#41  0x7f58285ccecb in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x69b
#42  0x7f5828ac03f6 in QAbstractButton::clicked(bool) from /lib64/libQt5Widgets.so.5+0x46
#43  /lib64/libQt5Widgets.so.5(+0x26461e) [0x7f5828ac061e]
#44  /lib64/libQt5Widgets.so.5(+0x265a63) [0x7f5828ac1a63]
#45  0x7f5828ac1c25 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5Widgets.so.5+0xe5
#46  0x7f5828a0e34e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#47  0x7f58289cbad6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#48  0x7f58289d53a3 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x583
#49  0x7f5829c9d4e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#50  0x7f58285a2df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#51  0x7f58289d44b7 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /lib64/libQt5Widgets.so.5+0x1b7
#52  /lib64/libQt5Widgets.so.5(+0x1ce0dd) [0x7f5828a2a0dd]
#53  /lib64/libQt5Widgets.so.5(+0x1d0f6c) [0x7f5828a2cf6c]
#54  0x7f58289cbad6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#55  0x7f58289d5150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#56  0x7f5829c9d4e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#57  0x7f58285a2df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#58  0x7f5826954c43 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /lib64/libQt5Gui.so.5+0x6f3
#59  0x7f582695646b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /lib64/libQt5Gui.so.5+0x26b
#60  0x7f582693256b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Gui.so.5+0xbb
#61  /lib64/libQt5XcbQpa.so.5(+0x76b5e) [0x7f581c53eb5e]
#62  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x160) [0x7f5825f85510]
#63  /lib64/libglib-2.0.so.0(+0x518a0) [0x7f5825f858a0]
#64  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7f5825f85943]
#65  0x7f58285f7d85 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x65
#66  0x7f58285a1cfb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0x12b
#67  0x7f58285a9a26 in QCoreApplication::exec() from /lib64/libQt5Core.so.5+0x96
#68  0x7f5829c243a5 in Gui::Application::runApplication() from /usr/lib64/freecad/lib/libFreeCADGui.so+0x16f5
#69  FreeCAD(main+0x6a6) [0x55b7ff9a1be6]
#70  /lib64/libc.so.6(__libc_start_main+0xf3) [0x7f5827f861a3]
#71  FreeCAD(_start+0x2e) [0x55b7ff9a1f4e]

Comment 1 Nick Price 2020-01-04 00:52:19 UTC
This may be a duplicate of #1766171 https://bugzilla.redhat.com/show_bug.cgi?id=1766171

Looks like a fix is in the testing repos

Comment 2 Richard Shaw 2020-01-06 17:27:10 UTC
Can you confirm if the packages that recently went to stable fix the problem?

It looks like you may be running my COPR as the release looks the same as the update. You may need to manually remove those packages first and then re-install from the Fedora repos.

Comment 3 Fedora Update System 2020-01-17 14:23:54 UTC
FEDORA-2020-6840f47e41 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 4 Fedora Update System 2020-01-17 14:23:56 UTC
FEDORA-2020-bb7ff34fc3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 5 Fedora Update System 2020-01-18 01:25:30 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 6 Fedora Update System 2020-01-18 01:44:18 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 7 Fedora Update System 2020-01-26 01:00:31 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-01-27 11:26:00 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.