Bug 1787418 - OLM descriptors are missing
Summary: OLM descriptors are missing
Keywords:
Status: CLOSED DUPLICATE of bug 1780378
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-02 18:55 UTC by Tom Buskey
Modified: 2020-01-02 18:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-02 18:58:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tom Buskey 2020-01-02 18:55:56 UTC
Description of problem:
oc explain output for most of the operator objects are missing the proper information.

oc explain THE_OBJECT

PackageManifest and CatalogSourceConfig objects are successful


Version-Release number of selected component (if applicable):

oc version
  Client Version: openshift-clients-4.3.0-201910250623-88-g6a937dfe
  Server Version: 4.3.0-0.nightly-2020-01-02-081435
  Kubernetes Version: v1.16.2

How reproducible:
Run the oc explain commands

Steps to Reproduce:
1. oc explain InstallPlan
2. oc explain ClusterServiceVersion
3. oc explain Subscription
4. oc explain CatalogSource
5. oc explain OperatorSource
6. oc explain OperatorGroup

Actual results:
oc explain THE_OBJECT
KIND:     THE_OBJECT
VERSION:  operators.coreos.com/v1alpha1

DESCRIPTION:
     <empty>


Expected results:
See https://polarion.engineering.redhat.com/polarion/#/project/OSE/workitem?id=OCP-24818 

DESCRIPTION field should not be empty.
FIELDS field should exist with entries for each field.  Usually there is a status object with a description of it at the end

ex: status    <Object>
     The status of the CatalogSource



Additional info:

Comment 1 Evan Cordell 2020-01-02 18:58:44 UTC

*** This bug has been marked as a duplicate of bug 1780378 ***


Note You need to log in before you can comment on or make changes to this bug.