Bug 178745 - Cannot access the Hardware Clock at startup
Cannot access the Hardware Clock at startup
Status: CLOSED DUPLICATE of bug 182597
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
ia64 Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-01-23 17:57 EST by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 16:35:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Émeric Maschino 2006-01-23 17:57:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
At startup, I'm getting

Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.

Running /sbin/hwclock --debug as a user gives the same output. Here's the output of /sbin/hwclock --debug as root:

hwclock from util-linux-2.13-pre6
Using /dev/efirtc interface to clock.
Last drift adjustment done at 1138050546 seconds after 1969
Last calibration done at 1138050546 seconds after 1969
Hardware clock is on local time
Assuming hardware clock is kept in local time.
Waiting for clock tick...
/dev/efirtc does not have interrupt functions. Waiting in loop for time from /dev/efirtc to change
...got clock tick
Time read from Hardware Clock: 2006/01/24 00:57:05
Hw clock time : 2006/01/24 00:57:05 = 1138060625 seconds since 1969
mar 24 jan 2006 00:57:05 CET  -0.458688 seconds

I don't see any problem here, so maybe is it a synchronization issue at boot time (initscripts-related)?

I don't know when this problem appears since I'm only with Fedora since January 10th and this issue was already there.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up Fedora Core IA-64 devel
2.
3.
  

Additional info:
Comment 1 Émeric Maschino 2006-01-28 06:19:14 EST
I should add that the same message is displayed when shutting down the system,
not only at startup.
Comment 2 Karel Zak 2006-02-07 14:47:00 EST
Please, try it with the latest devel version (>=util-linux-2.13-0.13).
Comment 3 Émeric Maschino 2006-02-07 15:55:15 EST
The problem is still there with util-linux 2.13-0.14
Comment 4 Karel Zak 2006-02-23 16:35:14 EST
Please, checks your logs for audit messages. It's possible that the problem is
based on missing access permissions to /dev/efirtc. For more details see bug
#182597 and bug #182598. Thanks.

*** This bug has been marked as a duplicate of 182597 ***

Note You need to log in before you can comment on or make changes to this bug.