Bug 182597 - ia64: /dev/efirtc access blocked by selinux
ia64: /dev/efirtc access blocked by selinux
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 178745 (view as bug list)
Depends On:
Blocks: fedora-ia64 182598 191136
  Show dependency treegraph
 
Reported: 2006-02-23 11:13 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-02-23 11:13:41 EST
Description of problem: 
 
On ia64 platforms, hwclock is accessed via /etc/efirtc.  Access to this file 
is blocked by selinux as no policy for file access exists. 
 
Version-Release number of selected component (if applicable):  latest rawhide 
pull (fedora-devel branch) 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. Install Fedora ia64 
2. Boot. 
3. 
   
Actual results: 
 
Following error is seen in dmesg: 
 
audit(1140618354.548:2): avc:  denied  { read } for  pid=3012 comm="hwclock" 
name="efirtc" dev=tmpfs ino=4860 scontext=system_u:system_r:hwclock_t:s0 
tcontext=system_u:object_r:device_t:s0 tclass=chr_file 
 
and following is seen on console: 
 
Cannot access the Hardware Clock via any known method. 
Use the --debug option to see the details of our search for an access method. 
Setting clock  (localtime): Tue Feb 21 20:00:15 EST 2006 [  OK  ] 
Starting udev  
 
Expected results: 
 
No errors should be seen. 
 
Additional info: Already talked with dwalsh regarding this issue.  Test  
selinux-policy provided solves this issue.
Comment 1 Prarit Bhargava 2006-02-23 11:16:57 EST
Sorry -- that should read "/dev/efirtc" not "/etc/efirtc". 
 
 
Comment 2 Karel Zak 2006-02-23 16:35:16 EST
*** Bug 178745 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2006-05-09 08:23:56 EDT
Fixed in selinux-policy-targeted-1.17.30-2.135
Comment 5 Émeric Maschino 2006-05-12 05:16:36 EDT
(In reply to comment #2)
> *** Bug 178745 has been marked as a duplicate of this bug. ***

I don't think that bug #178745 is a duplicate of this one. Otherwise, it means
that the problem is still present, with selinux-policy-targeted-2.2.38-5
Comment 6 Daniel Walsh 2007-08-22 10:16:28 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.