Bug 1787994 - [geo-rep] Help for positional argument SLAVE in schedule_georep.py.in isn't clear.
Summary: [geo-rep] Help for positional argument SLAVE in schedule_georep.py.in isn't c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.5
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: RHGS 3.5.z Batch Update 3
Assignee: Sunny Kumar
QA Contact: Leela Venkaiah Gangavarapu
URL:
Whiteboard:
Depends On: 1786276
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-06 04:32 UTC by Kshithij Iyer
Modified: 2020-12-17 04:51 UTC (History)
11 users (show)

Fixed In Version: glusterfs-6.0-38
Doc Type: No Doc Update
Doc Text:
Clone Of: 1786276
Environment:
Last Closed: 2020-12-17 04:51:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5603 0 None None None 2020-12-17 04:51:38 UTC

Description Kshithij Iyer 2020-01-06 04:32:44 UTC
+++ This bug was initially created as a clone of Bug #1786276 +++

Description of problem:
SLAVE positional argument doesn't provide a clear picture of what it is when compared to mastervol and slavevol in schedule_georep.py.in. It would be better if we change it to something like "Slave hostame (<username>@SLAVEHOST or SLAVEHOST)"

Present:
----------
positional arguments:
  mastervol            Master Volume Name
  SLAVE                SLAVEHOST or root@SLAVEHOST or user@SLAVEHOST 
  slavevol             Slave Volume Name


Suggested:
-----------
positional arguments:
  mastervol            Master Volume Name
  SLAVE                Slave hostname (<username>@SLAVEHOST or SLAVEHOST)
  slavevol             Slave Volume Name


Version-Release number of selected component (if applicable):
Whatever it the latest

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2019-12-24 07:38:05 UTC ---

REVIEW: https://review.gluster.org/23919 ([geo-rep] Improving help message in schedule_georep.py.in) posted (#1) for review on master by Kshithij Iyer

--- Additional comment from Worker Ant on 2020-01-06 04:06:56 UTC ---

REVIEW: https://review.gluster.org/23919 ([geo-rep] Improving help message in schedule_georep.py.in) merged (#5) on master by Kshithij Iyer

Comment 12 errata-xmlrpc 2020-12-17 04:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (glusterfs bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5603


Note You need to log in before you can comment on or make changes to this bug.