Bug 17881 - Error installing from hard drive
Summary: Error installing from hard drive
Status: CLOSED DUPLICATE of bug 18019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 21:28 UTC by David Phillips
Modified: 2007-04-18 16:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 22:10:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Phillips 2000-09-26 21:28:50 UTC
I received an error doing an install from the hard drive with a boot 
floppy. The installer ran normally until I got to the screen with the 
message, "Reading Package Information." Then I got an error message.
Here is the diagnostic data that the installer wrote to a floppy disk.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in 
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: quota

Local variables in innermost frame:
self: <comps.HeaderList instance at 821b950>
item: quota

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>

Comment 1 Michael Fulbright 2000-09-29 15:36:28 UTC
This is mostly likely because the hard drive image of Red Hat 7.0 is incomplete
or corrupted. How did you
create the hard drive image to install from?

Comment 2 andydeck 2000-10-03 16:46:55 UTC
I had something similar to this happen on an attempted laptop install(upgrade specifically).  On the first attempt, I had used XCOPY to copy the contents 
of the two i386 install CDs to a DOS partition.  Errors similar to the above occurred.  On the second attempt, I followed the README instructions :) and 
booted under my existing Linux to use 'cp -a' for the copy.  Second attempt worked w/o errors.

Comment 3 Michael Fulbright 2000-10-03 19:09:30 UTC
Please send me  the md5sum of the quota package in your tree - it appears to be
corrupt.

Comment 4 David Phillips 2000-10-03 23:50:55 UTC
I created the Hard Drive image by following the directions in 
http://www.redhat.com/download/howto_download.html. I downloaded all the files 
in RedHat/RPMS and RedHat/base onto my hard drive (onto the partition 
on /dev/hda5). I booted the machine with a boot floppy. I'm already running 
redhat 6.2 so I selected the upgrade option. The installer ran normally until 
the error message described earlier was received. 

Just in case, I had missed a file, I redownloaded the 7.0 files again and 
attempted the reinstallation - with the same results.

Comment 5 Michael Fulbright 2000-10-04 16:40:08 UTC
Be sure to download with the binary ftp option.

*** This bug has been marked as a duplicate of 18019 ***

Comment 6 David Phillips 2000-10-04 16:56:13 UTC
I did use binary mode for my downloads. 

Now I'm confused. I see this report linked to other duplicate reports, all 
moved to closed or resolved states but I don't see what the fix is.

Comment 7 Michael Fulbright 2000-10-04 22:10:51 UTC
This can only happen if something was wrong with the tree anaconda was
installing from.
Since this is a hard drive install then the user created the install tree.  My
suggestion is to try again (maybe the mirror had a bad copy of the files).


*** This bug has been marked as a duplicate of 18019 ***


Note You need to log in before you can comment on or make changes to this bug.