Bug 1788136 - Console operator degraded in IPv6 cluster [openshift-4.4]
Summary: Console operator degraded in IPv6 cluster [openshift-4.4]
Keywords:
Status: CLOSED DUPLICATE of bug 1794546
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1788164
TreeView+ depends on / blocked
 
Reported: 2020-01-06 14:18 UTC by Pawel Krupa
Modified: 2020-01-30 01:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1788164 (view as bug list)
Environment:
Last Closed: 2020-01-30 01:58:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
must gather (18.92 MB, application/gzip)
2020-01-06 14:18 UTC, Pawel Krupa
no flags Details
must_gather.zip (13.16 MB, application/zip)
2020-01-08 16:19 UTC, Pawel Krupa
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1788135 0 unspecified CLOSED Authentication operator is degraded in IPv6 cluster 2021-02-22 00:41:40 UTC

Description Pawel Krupa 2020-01-06 14:18:25 UTC
Created attachment 1650120 [details]
must gather

Description of problem:
Console operator is degraded causing the installation to fail

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start an IPv6 cluster


Actual results:
Installation fails with the following message:

```
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Working towards 4.3.0-0.nightly-2019-12-18-145749-ipv6.1: 100% complete 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
ERROR Cluster operator authentication Degraded is True with RouteHealthDegradedFailedGet: RouteHealthDegraded: failed to GET route: net/http: TLS handshake timeout 
INFO Cluster operator authentication Progressing is Unknown with NoData:  
INFO Cluster operator authentication Available is Unknown with NoData:  
INFO Cluster operator console Progressing is True with SyncLoopRefreshProgressingInProgress: SyncLoopRefreshProgressing: Working toward version 4.3.0-0.nightly-2019-12-18-145749-ipv6.1 
INFO Cluster operator console Available is False with DeploymentAvailableInsufficientReplicas: DeploymentAvailable: 0 pods available for console deployment 
INFO Cluster operator insights Disabled is False with :  
FATAL failed to initialize the cluster: Some cluster operators are still updating: authentication, console
```


Expected results:
Installation succeeds and operator is not degraded


Additional info:

Comment 1 bpeterse 2020-01-08 15:51:19 UTC
I was not able to open the attached must-gather file, corrupted?
Is there any further information that can be provided, such as the architecture/platform?

Comment 2 Pawel Krupa 2020-01-08 16:19:46 UTC
Created attachment 1650785 [details]
must_gather.zip

Everything was done on AWS in us-east-1 region.

I have attached must-gather in zip format

Comment 3 bpeterse 2020-01-30 01:58:46 UTC
I believe we accidentally made a duplicate of this bug, fixed and verified.

https://bugzilla.redhat.com/show_bug.cgi?id=1794546

*** This bug has been marked as a duplicate of bug 1794546 ***


Note You need to log in before you can comment on or make changes to this bug.