Bug 1794546 - Console and console operator should support IPv6
Summary: Console and console operator should support IPv6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1788136 (view as bug list)
Depends On:
Blocks: 1788164 1794548
TreeView+ depends on / blocked
 
Reported: 2020-01-23 19:39 UTC by bpeterse
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1794548 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:26:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 375 None closed Bug 1794546: Console-1933: IPv6 support (simpler alternative) 2020-04-21 15:33:24 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:08 UTC

Description bpeterse 2020-01-23 19:39:51 UTC
Description of problem:

Console, downloads deployment, and console operator will not run on an IPv6 cluster.  Some configurations need updating to support IPv6.

Comment 2 bpeterse 2020-01-28 21:51:33 UTC
PR also opened to backport to 4.3
- https://github.com/openshift/console-operator/pull/376
For related bug https://bugzilla.redhat.com/show_bug.cgi?id=1794548

Comment 3 Russell Bryant 2020-01-28 21:53:27 UTC
I've tested these changes successfully

Comment 4 bpeterse 2020-01-30 01:58:46 UTC
*** Bug 1788136 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-05-04 11:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.