Bug 1788574 - [RFE] DNF Support post-transaction actions (plugin)
Summary: [RFE] DNF Support post-transaction actions (plugin)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.4
Hardware: All
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Jaroslav Rohel
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-07 14:27 UTC by Markus Schibli
Modified: 2020-09-09 13:22 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-core-4.0.12-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:13 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 967264 None None None 2020-01-07 14:27:24 UTC
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:22 UTC

Description Markus Schibli 2020-01-07 14:27:25 UTC
Description of problem:

yum has a plugin for doing some actions after a transaction is finished which is very useful and was used by customer with yum in RHEL7. Please add support for post-transaction to dnf in RHEL8. The post-transaction plugin has already been added to dnf in upstream Fedora. For further information, please have a look at https://bugzilla.redhat.com/show_bug.cgi?id=967264 (which is also linked to this RFE)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
In RHEL8 dnf does not have the plugin "post-transaction" included 

Expected results:
Include the dnf plugin post-transaction in RHEL8.x

Additional info:

Comment 1 Daniel Mach 2020-01-08 14:17:15 UTC
This has been fixed in upstream: https://github.com/rpm-software-management/dnf-plugins-core/pull/366
and Fedora: bug#967264

It's already part of rebased dnf-plugins-core version that is going to be part of RHEL 8.2 release.

Comment 7 mhoward 2020-03-17 16:32:06 UTC
Building dnf-plugins-core-4.0.12-1.el8.src.rpm generates python3-dnf-plugin-post-transaction-actions-4.0.12-1.el8.noarch.rpm which doesn't seem to be available in RHEL 8.2 BETA. Will python3-dnf-plugin-post-transaction-actions-4.0.12-1.el8.noarch.rpm be included in RHEL 8.2 RELEASE?

Comment 8 Kyle Walker 2020-03-18 12:19:54 UTC
@mhoward,

You are correct, the update to the dnf-plugins-core which includes python3-dnf-plugin-post-transaction-actions is not currently available within the 8.2 Beta compose. However, it is still anticipated that the change will be available with the full RHEL 8.2 release. Assuming that there are no issues encountered with the change between now and the general availability date.

Have a great week!

Comment 10 errata-xmlrpc 2020-04-28 16:49:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.