Bug 967264 - [plugins] Support post-transaction actions [NEEDINFO]
Summary: [plugins] Support post-transaction actions
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 19
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1038936 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-26 05:58 UTC by Heiko Adams
Modified: 2015-11-16 12:35 UTC (History)
6 users (show)

Fixed In Version: dnf-0.4.10-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1220182 (view as bug list)
Environment:
Last Closed: 2014-01-04 19:52:53 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
LaurenWBard: needinfo? (akozumpl)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1220182 None None None Never

Description Heiko Adams 2013-05-26 05:58:28 UTC
Description of problem:
yum has a plugin for doing some actions after a transaction is finished which is IMHO very useful. Please add support for those post-transaction actions to dnf.

Comment 1 Ales Kozumplik 2013-05-27 07:28:41 UTC
DNF doesn't yet provide a plugin API so that should come first. Leaving this open until then, shouldn't be a problem.

Comment 2 Ales Kozumplik 2013-12-06 10:00:08 UTC
*** Bug 1038936 has been marked as a duplicate of this bug. ***

Comment 3 Ales Kozumplik 2013-12-06 15:25:46 UTC
Fixed by 6e60010 on master, the new API will be included in dnf-0.4.10.

Comment 4 Fedora Update System 2014-01-02 10:09:29 UTC
dnf-0.4.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.10-1.fc20

Comment 5 Fedora Update System 2014-01-03 08:41:12 UTC
Package dnf-0.4.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0089/dnf-0.4.10-1.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-01-04 19:52:53 UTC
dnf-0.4.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Lauren 2015-04-24 01:03:16 UTC
Ales,

This bug should be re-opened, as the request for a dnf equivalent to yum-plugin-post-transaction-action has not been fulfilled, only the first step towards that goal (support for plugins in dnf) has been addressed thus far.

Comment 8 Lauren 2015-04-24 01:05:16 UTC
Typo -- the correct name for the package is yum-plugin-post-transaction-actions (with an "s" at the end)

Comment 9 Freddy Willemsen 2015-11-16 12:35:25 UTC
Agreed, I would love to see the equivalent of yum-plugin-post-transaction-actions in DNF. I miss it dearly. So why this bug was closed is beyond me.


Note You need to log in before you can comment on or make changes to this bug.