Bug 1789000 - node-exporter not working in IPv6 environment
Summary: node-exporter not working in IPv6 environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1789001
TreeView+ depends on / blocked
 
Reported: 2020-01-08 14:44 UTC by Pawel Krupa
Modified: 2020-05-04 11:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1789001 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:23:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github coreos kube-prometheus pull 326 0 None closed IPv6 compatibility 2020-04-28 16:04:30 UTC
Github coreos kube-prometheus pull 328 0 None closed Fix typo in node-exporter DaemonSet 2020-04-28 16:04:30 UTC
Github openshift cluster-monitoring-operator pull 591 0 None closed Bug 1784144: Bump jsonnet dependencies 2020-04-28 16:04:30 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:23:40 UTC

Description Pawel Krupa 2020-01-08 14:44:16 UTC
Description of problem:
node-exporter cannot start due to incorrect IP address representation


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Junqi Zhao 2020-03-24 05:51:05 UTC
Tested with 4.4.0-0.nightly-2020-03-23-010639, issue is fixed
$ oc -n openshift-monitoring get pod -o wide | grep node-exporter
node-exporter-h4wlq                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::143    master-2.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-n8nd5                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::144    worker-3.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-s45vn                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::115    master-0.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-s4lx2                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::107    worker-0.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-vwq9j                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::142    worker-1.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-xh4rt                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::129    master-1.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
node-exporter-xtqm7                            2/2     Running   2          15h     fd2e:6f44:5dd8:c956::119    worker-2.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
$ oc -n openshift-monitoring get ds/node-exporter -oyaml | grep "secure-listen-address"
        - --secure-listen-address=[$(IP)]:9100

All node-exporter endpoints are UP

Comment 4 errata-xmlrpc 2020-05-04 11:23:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.