This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 178909 - Tables image positions broken on reload
Tables image positions broken on reload
Status: CLOSED DUPLICATE of bug 178910
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 07:48 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 08:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Example file demonstrating the table problem (123.02 KB, application/vnd.oasis.opendocument.text)
2006-01-25 07:48 EST, Paul F. Johnson
no flags Details
anchoring modified to be "as character" (124.08 KB, application/vnd.oasis.opendocument.text)
2006-01-25 08:19 EST, Caolan McNamara
no flags Details

  None (edit)
Description Paul F. Johnson 2006-01-25 07:48:42 EST
Description of problem:
If I create a table and insert into it images which I then position at the
bottom of the cell, save, close and load, the image positions on reload are not
in the same place as when I saved.

Version-Release number of selected component (if applicable):
2.0.1.1-7.2

How reproducible:
Always

Steps to Reproduce:
1. Load in the example file attached. The image in the top right hand column is
incorrectly placed
2. Move the image so it is correctly placed, save
3. Reload
  
Actual results:
Image position is in the incorrect place

Expected results:
Image positions should be the same as when the file is saved

Additional info:
Comment 1 Paul F. Johnson 2006-01-25 07:48:42 EST
Created attachment 123668 [details]
Example file demonstrating the table problem
Comment 2 Caolan McNamara 2006-01-25 08:15:58 EST
This is part of the same layout problem as the other hanging bug with this
document, the layout "fail safe loop-detection" sticks the graphic in the wrong
place, rather than get caught in a infinite loop, in the other case the
loop-detection fails. One of the reasons I think we should default to anchoring
"as character" to reduce the  amount of complex laying situations which anchor
to paragraph gets us stuck in :-(

*** This bug has been marked as a duplicate of 178910 ***
Comment 3 Caolan McNamara 2006-01-25 08:19:12 EST
Created attachment 123670 [details]
anchoring modified to be "as character"

Doesn't fix the bug, but here's the document with a workaround in place. i.e.
changing anchoring to the simpler "as character" mode

Note You need to log in before you can comment on or make changes to this bug.