Bug 17893 - emacs refuses to read files
Summary: emacs refuses to read files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
: 17892 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 21:51 UTC by Michal Jaegermann
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 14:13:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2000-09-26 21:51:19 UTC
emacs-20.7-14 on Alpha opened under X (Gnome desktop) exits
immediately and quietly after any of the following:
'C-x C-f /usr'
'C-x C-f ~/'
'C-x C-f <any path starting with /usr, file or directory> 

'C-x C-f /' still works fine.

None of problems of that sort with emascs from 6.2 distribution for
Alpha.

   Michal
   michal@harddata.com

Comment 1 Trond Eivind Glomsrxd 2000-09-26 21:55:10 UTC
Platformspecific - assigning to Matt.

Comment 2 Aaron Brown 2000-10-17 13:15:30 UTC
This problem appears to be fixed in emacs-20.7-16.  I was able to open files in
the /usr and ~/ dirs without any problem.


Comment 3 Matt Wilson 2000-10-17 14:13:27 UTC
Oh, sorry - I didn't see this assigned to me.  The problem was the gcc aliased
store bug, it was clobbering lisp object structure members during
initialization, pushing invalid lisp objects on the stack, then when the garbage
collector tried to collect it things went bad.

Fixed when built with the latest gcc.


Comment 4 Matt Wilson 2000-10-19 04:50:24 UTC
*** Bug 17892 has been marked as a duplicate of this bug. ***

Comment 5 Matt Wilson 2000-10-19 04:52:20 UTC
*** Bug 17892 has been marked as a duplicate of this bug. ***

Comment 6 Matt Wilson 2000-10-19 04:52:52 UTC
*** Bug 17892 has been marked as a duplicate of this bug. ***

Comment 7 Michal Jaegermann 2000-10-19 07:01:37 UTC
Indeed, I substituted emacs from rawhide (emacs-20.7-15) and so far no
nasty surprises.


Note You need to log in before you can comment on or make changes to this bug.