Bug 1789644 - [HPE 8.2 Bug] networkmanger domain_search list removed dots
Summary: [HPE 8.2 Bug] networkmanger domain_search list removed dots
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: pre-dev-freeze
: 8.2
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1699080 1776957
TreeView+ depends on / blocked
 
Reported: 2020-01-10 00:40 UTC by Randy Wright
Modified: 2020-04-28 16:54 UTC (History)
15 users (show)

Fixed In Version: NetworkManager-1.22.0-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:38 UTC

Description Randy Wright 2020-01-10 00:40:34 UTC
Description of problem:
This seems to be consistent among several SUTs updated to RHEL82 snapshot2 at HPE: the DNS domain_search list is being striped of dots.  Before the snapshot2 update:

messages-20191216:Dec 11 04:52:58 dl360g91 NetworkManager[2036]: <info>  [1576065178.9771] dhcp4 (eno1): option domain_search        => 'ftc.rdlabs.hpecorp.net americas.hpqcorp.net'

After updating:

messages-20191216:Dec 13 11:43:17 dl360g91 NetworkManager[2030]: <info>  [1576262597.9228] dhcp4 (eno1): option domain_search        => 'ftcrdlabshpecorpnet americashpqcorpnet'

This winds up in /etc/resolv.conf thusly:

search ftcrdlabshpecorpnet americashpqcorpnet

And of course doesn't achieve the desired result.


Version-Release number of selected component (if applicable):
RHEL8.2 internal snapshot2

How reproducible:
Apparently all our systems installed or updated to RHEL82 snapshot 2.


Steps to Reproduce:
1. Install RHEL82 snapshot2
2. Notice default domainname searches no longer work


Actual results:
For one obviouse example, nslookup of an expected host on the same subnet fails 

Expected results:
nslookup of another host on same subnet works

Additional info:
I had submitted an sosreport from an affected system in bug 1783425.  I hadn't reconized this problem at the time, but the /var/log/messages in that sosreport shows results before and after the update to snapshot 2.
Dec 13 04:52:58 dl360g91 NetworkManager[2036]: <info>  [1576237978.5615] dhcp4 (eno1): option domain_search        => 'ftc.rdlabs.hpecorp.net americas.hpqcorp.net'
Dec 13 10:46:24 dl360g91 NetworkManager[2026]: <info>  [1576259184.1605] dhcp4 (eno1): option domain_search        => 'ftcrdlabshpecorpnet americashpqcorpnet'

Comment 1 Thomas Haller 2020-01-10 17:48:03 UTC
fixed upstream by https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/ea22135384edaf57a41293bd517ff1445b8c88a8


As workaround with beta snapshot, you could use

```
[main]
dhcp=systemd
```

in /etc/NetworkManager/conf.d/99-my-temporary-workaround.conf

Comment 2 Thomas Haller 2020-01-10 17:49:57 UTC
actually, it's a duplicate of bug 1783981.

Comment 3 Randy Wright 2020-01-10 18:05:08 UTC
If you dup this bug to 1783981, please grant HPE access to 1783981 so we can monitor status of the fix.

Comment 4 Thomas Haller 2020-01-10 18:20:03 UTC
(In reply to Randy Wright from comment #3)
> If you dup this bug to 1783981, please grant HPE access to 1783981 so we can
> monitor status of the fix.

I didn't close this bug as duplicate exactly because you cannot access the other bug.

This bug will go it's normal way. The status MODIFIED is correct. No need to reset the state to NEW.

Comment 5 Trinh Dao 2020-02-04 20:42:03 UTC
Monte, can you grant HPE access to duplicate bug 1783981?

thanks,
trinh

Comment 6 Monte Knutson 2020-02-10 15:30:29 UTC
requested:

  fix is in NetworkManager-1.22.0-2.el8

Monte

Comment 7 Trinh Dao 2020-02-13 18:19:51 UTC
Sushil, 
can you tell me if NetworkManager-1.22.0-2.el8 is included in the latest RHEL8.2 Beta build?

thanks,
trinh

Comment 8 Randy Wright 2020-02-13 22:22:02 UTC
With RHEL-8.2.0_Beta_1.0Server-x86_64 installed, I find I have the desired version of Network Manager:

[root@fingal01 ~]# rpm -qa > qa.txt
[root@fingal01 ~]# grep NetworkManager-1.22 qa.txt
NetworkManager-1.22.0-2.el8.x86_64

So I remove the 99-temporary-workaround.conf file I had created per the comment 1 suggestion and rebooted.

Upon rebooting, I was able to verify that the symptoms I reported originally are no longer occurring, for example:

[root@fingal01 ~]# grep domain_search /var/log/messages|tail -2
Feb 13 15:13:20 fingal01 NetworkManager[3845]: <info>  [1581632000.6451] dhcp4 (ens1f0): option domain_search        => 'ftc.rdlabs.hpecorp.net americas.hpqcorp.net'
Feb 13 15:13:20 fingal01 NetworkManager[3845]: <info>  [1581632000.6452] dhcp4 (ens1f0): option requested_domain_search => '1'

I can clearly see the dots that were missing from the domain_search string due to the reported bug are indeed present.

And /etc/resolv.conf is constructed as expected:

[root@fingal01 ~]# cat /etc/resolv.conf 
# Generated by NetworkManager
search ftc.rdlabs.hpecorp.net americas.hpqcorp.net
nameserver 16.110.135.51
nameserver 16.110.135.52

I am marking this HPE verified.

Comment 11 Beniamino Galvani 2020-02-14 08:39:46 UTC
(In reply to Trinh Dao from comment #7)
> Sushil, 
> can you tell me if NetworkManager-1.22.0-2.el8 is included in the latest
> RHEL8.2 Beta build?

Yes, it is.

Comment 12 Vladimir Benes 2020-02-18 18:18:47 UTC
covered by:
dhcp_option_domain_search

Comment 14 errata-xmlrpc 2020-04-28 16:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.