Bug 1789857 - [oc-cli]oc-config command does not work with `--kubeconfig`
Summary: [oc-cli]oc-config command does not work with `--kubeconfig`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1802505 (view as bug list)
Depends On: 1788194
Blocks: 1789869 1802506 1802509
TreeView+ depends on / blocked
 
Reported: 2020-01-10 15:18 UTC by Maciej Szulik
Modified: 2020-03-10 23:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788194
: 1789869 (view as bug list)
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 247 0 None closed Bug 1789857: allow --config and --kubeconfig 2020-12-09 15:57:38 UTC
Red Hat Product Errata RHBA-2020:0676 0 None None None 2020-03-10 23:53:17 UTC

Comment 1 Maciej Szulik 2020-02-13 13:52:10 UTC
*** Bug 1802505 has been marked as a duplicate of this bug. ***

Comment 4 zhou ying 2020-02-21 03:40:57 UTC
Can't reproduce the issue now:
[zhouying@dhcp-140-138 ~]$ oc version -o yaml 
clientVersion:
  buildDate: "2020-02-20T17:54:29Z"
  compiler: gc
  gitCommit: 5605222f8033873abf2b352c72dc6fb02831f577
  gitTreeState: clean
  gitVersion: v4.3.3
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64


[zhouying@dhcp-140-138 ~]$ oc config view
apiVersion: v1
clusters: []
contexts: []
current-context: ""
kind: Config
preferences: {}
users: []


[zhouying@dhcp-140-138 ~]$ oc --kubeconfig /tmp/tmp.config config view
apiVersion: v1
clusters:
- cluster:
    insecure-skip-tls-verify: true
    server: https://xxxx.openshift.com:6443
  name: xxxx-openshift-com:6443
- cluster:
    insecure-skip-tls-verify: true
    server: https://yyyy.openshift.com:6443
  name: yyyy-openshift-com:6443

Comment 6 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.