Bug 1789869 - [oc-cli]oc-config command does not work with `--kubeconfig`
Summary: [oc-cli]oc-config command does not work with `--kubeconfig`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1802506 (view as bug list)
Depends On: 1788194 1789857
Blocks: 1802509
TreeView+ depends on / blocked
 
Reported: 2020-01-10 15:36 UTC by Maciej Szulik
Modified: 2020-03-04 04:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1789857
Environment:
Last Closed: 2020-03-04 04:51:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 248 None closed Bug 1789869: allow --config and --kubeconfig 2020-03-02 21:23:38 UTC
Red Hat Product Errata RHBA-2020:0614 None None None 2020-03-04 04:51:12 UTC

Comment 1 Maciej Szulik 2020-02-13 13:52:55 UTC
*** Bug 1802506 has been marked as a duplicate of this bug. ***

Comment 4 zhou ying 2020-02-24 02:31:21 UTC
Works now with latest oc client:
[root@dhcp-140-138 upgrade]# oc version -o yaml 
clientVersion:
  buildDate: "2020-02-21T20:26:40Z"
  compiler: gc
  gitCommit: 33d97ed617e022637cbac55be22003e54b1bd072
  gitTreeState: clean
  gitVersion: v4.2.21
  goVersion: go1.12.8
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 upgrade]# oc config view
apiVersion: v1
clusters: []
contexts: []
current-context: ""
kind: Config
preferences: {}
users: []


[root@dhcp-140-138 upgrade]# oc --kubeconfig /tmp/tm.sss config view
apiVersion: v1
clusters:
- cluster:
    insecure-skip-tls-verify: true
    server: https://xxxx.openshift.com:6443
  name: xxxx-openshift-com:6443

Comment 6 errata-xmlrpc 2020-03-04 04:51:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0614


Note You need to log in before you can comment on or make changes to this bug.