Bug 178987 - Partioning 3 sata hardrives either raid or not gives error
Partioning 3 sata hardrives either raid or not gives error
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 20:22 EST by Jkjgt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-28 00:43:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jkjgt 2006-01-25 20:22:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050603 Fedora/1.7.8-1.2.1.legacy

Description of problem:
System AMD 64 venice3200+ MSI k8ngm2-fid 2x512MB 3 250GB sata HD seagate ASUS DVD burner

Was able to format last week successfully with 2 drives some issues with ethernet and audio driver not resolved (was short a sata power cable so tested on 2 drives) Power cable arrived tried to reload with all 3 drives and now have persistant and repeatable problem.  I am currently trying to load all of linux4 perviously only took workstation entries (was testing only now trying for real).

Version-Release number of selected component (if applicable):
Fedora4 iso discs from website passed mediacheck

How reproducible:
Always

Steps to Reproduce:
1.start fedora4 disks
2.load nvidia sata driver
3.once preparing to load entire contents of linux comes back with the following
  

Actual Results:  I hope this is accurate  had to write it by hand.
traceback (most recent call last);
File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 873, in nextclicked
self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
disk.commit()
error: Error: Error informing the kernel about modifications to partion /dev/sdb1 - Device or resource busy. This means Linux won't know about any changes you made to /dev/sdb1 until you reboot- so you shouldn't mount it or use it in any way before rebooting

Expected Results:  clean load

Additional info:

This occured while trying to partition in Raid 5 then duplicated as Raid 0, and standard load JBODs.  Scratching my head.  Your wisdom would be most appreciated.  Thanks.
Jim
Comment 1 Jkjgt 2006-01-25 21:11:58 EST
Hi All,
   New find that may help track this down.  The new drive I added was added as
the   primary drive on the 2nd SATA device for this board.  I was wondering if
that had anything to do with anything, so transfered the new drive to the
secondary drive on the 1st SATA device for the board. I then proceeded to repeat
the procedure above but this time it appears to be working.  I tried the auto
setting which looked like it worked and now restarted and am installing as Raid
(1 for /boot, 0 for swap and 5 for / and /home).  It appears to be going well. 
So if I were to guess I would say that somehow having the 2 drives previously
formated and adding the 3rd drive on the primary of the 2nd SATA somehow fooled
something.  Hope this helps.  If I learn anything more I will post.
Thanks.
Jim
Comment 2 Jkjgt 2006-01-26 19:08:12 EST
Hi
Looks like I spoke too soon.  After waiting 24 hours I was still waiting for the
raid array to format.  Seems unlikely that this is a reasonable wait period even
for raid 5.   I am guessing this may have something to do with the bug.  Please
advise if you have any ideas.
Thanks.
Jim
Comment 3 Jkjgt 2006-01-26 20:08:13 EST
Latest news,
Tried to restart install and am getting the same error messages.  
Jim
Comment 4 Jeremy Katz 2006-01-28 00:43:53 EST

*** This bug has been marked as a duplicate of 160693 ***
Comment 5 Jkjgt 2006-01-28 11:40:06 EST
Hi Jeremy, 
   I took a look at 160693 and hate to admit I am so much of a noob that I am
not sure how to correct the version of anaconda that exists on my distro.  Is
there a corrected version I could use?  I could not find reference to it in the
thread listed.  Is there some reference as to how to patch the existing one?
Thanks.
Jim

Note You need to log in before you can comment on or make changes to this bug.